Bug 1320338 - Can't use hammer docker commands. API routes changed.
Summary: Can't use hammer docker commands. API routes changed.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Lukas Pramuk
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1317916 (view as bug list)
Depends On:
Blocks: 1315276
TreeView+ depends on / blocked
 
Reported: 2016-03-22 21:40 UTC by Partha Aji
Modified: 2019-09-26 14:47 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:28:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14322 None None None 2016-04-22 16:47:13 UTC

Description Partha Aji 2016-03-22 21:40:58 UTC
I think this may have been related to our move to Rails.

Comment 1 Partha Aji 2016-03-22 21:41:00 UTC
Created from redmine issue http://projects.theforeman.org/issues/14322

Comment 2 Partha Aji 2016-03-22 21:41:02 UTC
Upstream bug assigned to daviddavis@redhat.com

Comment 8 Lukas Pramuk 2016-03-31 16:55:58 UTC
VERIFIED.
@Sat6.2.0-Beta-Snap6

REPRO:

# hammer docker registry list
404 Resource Not Found
# hammer docker container list
404 Resource Not Found

vs.

FIX:

# hammer docker registry list
---|------|----
ID | NAME | URL
---|------|----
# hammer docker container list
---|--------------|-------------------------------------|--------|---------|-----------------
ID | NAME         | IMAGE REPOSITORY                    | TAG    | COMMAND | COMPUTE RESOURCE
---|--------------|-------------------------------------|--------|---------|-----------------
1  | busybox_hub  | busybox                             | latest | top     | local docker    
2  | busybox_hub  | busybox                             | latest | top     | remote docker   
3  | busybox_cv1  | default_organization-docker-busybox | latest | top     | local docker    
4  | busybox_cv2  | default_organization-docker-busybox | latest | top     | local docker    
6  | busybox_cv   | default_organization-docker-busybox | latest | top     | local docker    
7  | busybox_cv3  | default_organization-docker-busybox | latest | top     | local docker    
8  | busybox_cv5  | default_organization-docker-busybox | latest | top     | local docker    
9  | busybox_hub1 | busybox                             | latest | top     | remote docker   
---|--------------|-------------------------------------|--------|---------|-----------------

Comment 9 Adam Price 2016-03-31 21:52:02 UTC
*** Bug 1317916 has been marked as a duplicate of this bug. ***

Comment 10 Adam Price 2016-03-31 21:53:40 UTC
I'm curious why we have a fix verified downstream when it's still failing on a production install of katello master upstream? That seems backwards.

Comment 12 errata-xmlrpc 2016-07-27 09:28:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.