Bug 1320476 - Failed to upgrade qemu-kvm-tools-rhev from 2.3.0 to 2.5.0
Summary: Failed to upgrade qemu-kvm-tools-rhev from 2.3.0 to 2.5.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: x86_64
OS: Linux
high
unspecified
Target Milestone: rc
: ---
Assignee: Miroslav Rezanina
QA Contact: Chao Yang
URL:
Whiteboard:
: 1336646 1374263 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-23 10:14 UTC by yafu
Modified: 2016-11-07 21:02 UTC (History)
10 users (show)

Fixed In Version: qemu-kvm-rhev-2.6.0-6.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 21:02:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description yafu 2016-03-23 10:14:11 UTC
Description of problem:
Upgrade qemu-kvm-tools-rhev from 2.3.0-31 to 2.5.0.3, it failed with error: file /usr/share/qemu-kvm/tscdeadline_latency.flat from install of qemu-kvm-tools-rhev-10:2.5.0-3.el7.x86_64 conflicts with file from package qemu-kvm-tools-rhev-10:2.3.0-31.el7.x86_6. 


Version-Release number of selected component (if applicable):
qemu-kvm-tools-rhev-2.5.0-3.el7.x86_64
qemu-kvm-tools-rhev-2.3.0-31.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a host with qemu-kvm-tools-rhev-2.3.0-31.el7.x86_64;
2.Upgrade qemu-kvm-tools-rhev to qemu-kvm-tools-rhev-2.5.0-3.el7.x86_64
 #yum upgrade qemu-kvm-tools-rhev-2.5.0-3.el7.x86_64
  ...
  Transaction check error:
  file /usr/share/qemu-kvm/tscdeadline_latency.flat from install of qemu-kvm-tools-rhev-10:2.5.0-3.el7.x86_64 conflicts with file from package qemu-kvm-tools-rhev-10:2.3.0-31.el7.x86_64
  ...

Actual results:


Expected results:
Could upgrade to qemu-kvm-tools-rhev-2.5.0.3.el7.x86_64 successfully.

Additional info:
qemu-kvm-tools-rhev-2.5.0.1 and qemu-kvm-tools-rhev-2.5.0.2 can upgrade to qemu-kvm-tools-rhev-2.5.0.3 successfully.

Comment 1 Miroslav Rezanina 2016-05-24 10:26:00 UTC
*** Bug 1336646 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Nelson 2016-06-02 14:37:47 UTC
This is starting to have a negative impact. Raising priority to HIGH.

Comment 4 Florian Festi 2016-06-09 08:44:01 UTC
It looks like for some reason this is not really running as an update.

Can you please provide the complete yum output?

Comment 5 Florian Festi 2016-06-09 09:02:07 UTC
OK, I think I got the problem:

rpm in it's great wisdom determines the "color" (the package being 32 or 64 bit) by the contents of the files.

rpm -qp --qf="[%{filenames} %{filecolors}\n]" ~/Downloads/qemu-kvm-tools-rhev-2.3.0-31.el7.x86_64.rpm
/usr/bin/kvm_stat 0
/usr/share/qemu-kvm/tscdeadline_latency.flat 1


rpm -qp --qf="[%{filenames} %{filecolors}\n]" ~/Downloads/qemu-kvm-tools-rhev-2.6.0-1.el7.x86_64.rpm
/usr/bin/ivshmem-client 2
/usr/bin/ivshmem-server 2
/usr/bin/kvm_stat 0
/usr/share/qemu-kvm/tscdeadline_latency.flat 1

So it thinks qemu-kvm-tools-rhev-2.3.0-31.el7.x86_64.rpm is color 1 (aka i32). So the new package (which is correctly detected as 64 bit due to the new 64 bit tools in it) does not update it.

Whether using the file content in this way is a good idea is probably not for discussion as we probably can't change that within the RHEL release. Can you try to just Obsolete the 2.3 Package from the new one, please?

Comment 6 Markus Armbruster 2016-06-09 16:45:20 UTC
We should *not* package ivshmem-client and ivshmem-server!  These are example programs, not ready for production use and certainly not supportable in their current form.

Comment 7 Miroslav Rezanina 2016-06-15 13:07:46 UTC
Fix included in qemu-kvm-rhev-2.6.0-6.el7

Comment 9 Chao Yang 2016-09-06 05:50:52 UTC
-- Reproduced with qemu-kvm-rhev-2.5.0-4.el7

# rpm -Uvh qemu-kvm-rhev-2.5.0-4.el7/qemu-kvm-tools-rhev-2.5.0-4.el7.x86_64.rpm 
Preparing...                          ################################# [100%]
	file /usr/share/qemu-kvm/tscdeadline_latency.flat from install of qemu-kvm-tools-rhev-10:2.5.0-4.el7.x86_64 conflicts with file from package qemu-kvm-tools-rhev-10:2.3.0-31.el7_2.20.x86_64

# rpm -qpl qemu-kvm-rhev-2.5.0-4.el7/qemu-kvm-tools-rhev-2.5.0-4.el7.x86_64.rpm
/usr/bin/ivshmem-client
/usr/bin/ivshmem-server
/usr/bin/kvm_stat
/usr/share/qemu-kvm/tscdeadline_latency.flat


-- Verified pass with qemu-kvm-rhev-2.6.0-22.el7

# rpm -qpl qemu-kvm-tools-rhev-2.6.0-22.el7.x86_64.rpm
/usr/bin/kvm_stat
/usr/share/qemu-kvm/tscdeadline_latency.flat

# rpm -Uvh qemu-kvm-tools-rhev-2.6.0-22.el7.x86_64.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:qemu-kvm-tools-rhev-10:2.6.0-22.e################################# [ 50%]
Cleaning up / removing...
   2:qemu-kvm-tools-rhev-10:2.3.0-31.e################################# [100%]

Comment 10 Jeff Nelson 2016-09-20 13:18:03 UTC
*** Bug 1374263 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2016-11-07 21:02:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.