Bug 132050 - Evolution has an icon in both "Internet" and "office"
Evolution has an icon in both "Internet" and "office"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Dave Malcolm
:
: 136972 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-08 04:54 EDT by David Nielsen
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 13:47:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2004-09-08 04:54:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
evolution is referenced two times in the GNOME menu, we rightfully
should only do that once, the really kicker is that they aren't even
completely alike. one says "Email program" the other says "Evolution".
I take it that this has to do with the "preferred applications" settings.

Please correct.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
not needed

Additional info:
Comment 1 Need Real Name 2004-10-20 07:24:57 EDT
Same for me - until applying all the updates.
Now I have no Evolution icon at all :)
Comment 2 David Nielsen 2004-10-20 08:23:56 EDT
doh, I didn't notice that at all since I got so sick of the menu being
so badly configured - I added a launcher in my panel.
Comment 3 Dave Malcolm 2004-10-20 14:25:16 EDT
Works for me - I have a single "Evolution Email" menu item (in the
Internet menu), plus a launcher on the panel.

Please can you give more details of what you're seeing?
Comment 4 Need Real Name 2004-10-21 07:54:13 EDT
There is nothing mentioning Evolution under either the Internet or
Office menus.
Comment 5 Dave Malcolm 2004-10-21 14:29:35 EDT
wrt to comment #4: what version of these packages do you have
installed: - evolution
- redhat-menus

Comment 6 Nicholas Miell 2004-10-22 01:24:02 EDT
I'm also lacking any Evolution icons anywhere in the menu (and didn't
notice this thanks to the wonders of session management).

The evolution package seems to have completely lost the
/usr/share/applications/evolution-2.0.desktop file, which should be
providing the menu entry. (This appears to be because of bug #103826)

It still has /usr/share/applications/redhat-email.desktop, which (IMO)
shouldn't be present in the evolution package at all -- right now, RPM
lists it as being owned by both htmlview and evolution, and
considering that it calls launchmail and not evolution, it really
shouldn't be in the evolution package. (It has "NoDisplay=true", which
is why it doesn't show up in the menu at all.)

So, get rid of redhat-email.desktop, put evolution-2.0.desktop back,
and everything should be fine.
Comment 7 Need Real Name 2004-10-22 02:56:59 EDT
And here are the versions!

$ rpm -q redhat-menus
redhat-menus-1.12-1
$ rpm -q evolution
evolution-2.0.2-1
Comment 8 Dave Malcolm 2004-10-22 20:59:23 EDT
Thanks for the report; a fix should be appearing in evolution-2.0.2-3
Comment 9 Bill Nottingham 2004-10-25 17:39:31 EDT
*** Bug 136972 has been marked as a duplicate of this bug. ***
Comment 10 Dave Malcolm 2004-11-02 13:47:17 EST
The fix is now in rawhide (evolution-2.0.2-3 and redhat-menus-1.13-1)

Note You need to log in before you can comment on or make changes to this bug.