Bug 132052 - %post scriptlet fails
%post scriptlet fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-08 05:57 EDT by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 12:29:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-09-08 05:57:34 EDT
Description of problem:
Just completed an installation on x86_64 from the rawhide tree
containing rpmdb-fedora-2.91-0.20040907.x86_64.rpm.  I installed in
text mode.

The greeter screen would not display, and I traced it to pango failing
to read /etc/pango/pango.modules because it was absent.  This was in
/root/install.log:

# grep -nE '(xorg-x11-libs|pango)' install.log
262:Installing pango-1.5.2-2.i386.
263:/usr/bin/pango-querymodules-32: error while loading shared
libraries: libXft.so.2: cannot open shared object file: No such file
or directory
264:error: %post(pango-1.5.2-2) scriptlet failed, exit status 127
265:Installing pango-1.5.2-2.x86_64.
266:/usr/bin/pango-querymodules-64: error while loading shared
libraries: libXft.so.2: cannot open shared object file: No such file
or directory
267:error: %post(pango-1.5.2-2) scriptlet failed, exit status 127
280:Installing xorg-x11-libs-6.7.99.903-5.i386.
281:Installing xorg-x11-libs-6.7.99.903-5.x86_64.
660:Installing pango-devel-1.5.2-2.x86_64.

But since pango requires xorg-x11-libs, I'm not sure why they got
installed in the wrong order.

Removing and reinstalling pango (both arches) post-install fixed the
problem.

Version-Release number of selected component (if applicable):
pango-1.5.2-2

How reproducible:
100%
Comment 1 Owen Taylor 2004-09-08 09:56:04 EDT
Can't see how this would be caused by anything in the Pango 
packaging. Jonathan was helping QA with the same problem a
few days ago, Cc'ing in case he found anything out.
Comment 2 Jeremy Katz 2004-09-08 10:39:07 EDT
Jeff -- I haven't started poking this in earnest yet (tracking down a
couple of other things), but do you have any ideas off hand?

The order looks right on i386, but definitely seems a little bit off
for x86_64...
Comment 3 Jeff Johnson 2004-09-08 11:29:07 EDT
Get me access to an x86_64 and I'll dig out the problem.

Fix for rpm -Va on multilib same time ...
Comment 4 Jeremy Katz 2004-09-08 15:39:07 EDT
Fixed

Note You need to log in before you can comment on or make changes to this bug.