Bug 1320716 - RFE Sort volume quota <volume> list output alphabetically by path
Summary: RFE Sort volume quota <volume> list output alphabetically by path
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: All
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Manikandan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1330018
TreeView+ depends on / blocked
 
Reported: 2016-03-23 19:40 UTC by Steve D
Modified: 2016-06-16 14:01 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1330018 (view as bug list)
Environment:
Last Closed: 2016-06-16 14:01:30 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Steve D 2016-03-23 19:40:27 UTC
Description of problem:
Output of gluster volume quota <volume> list is not sorted alphabetically by path name.

Version-Release number of selected component (if applicable):
3.7.x

How reproducible:
Always

Steps to Reproduce:
1. gluster volume quota <volume> list
2.
3.

Actual results:
                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/data4/climate                           120.0TB     80%(96.0TB)   95.6TB  24.4TB              No                   No
/data4/climate/downscale/CMIP5            65.0TB     80%(52.0TB)   57.6TB   7.4TB             Yes                   No
/data4/forestry                           50.0GB     80%(40.0GB)   46.0GB   4.0GB             Yes                   No
/data4/strays                             85.0GB     80%(68.0GB)   80.8GB   4.2GB             Yes                   No
/data4/gis                                 2.2TB     80%(1.8TB)    2.1TB 108.5GB             Yes                   No
/data4/modperl                             1.0TB     80%(819.2GB)  948.3GB  75.7GB             Yes                   No
/data4/dem                                 1.0GB     80%(819.2MB)   0Bytes   1.0GB              No                   No
/projects/CanSISE                         10.0TB     80%(8.0TB)    3.5TB   6.5TB              No                   No
/projects/hydrology/archive0               5.0TB     80%(4.0TB)    4.7TB 282.2GB             Yes                   No
/projects/downscale-idf-ec                 5.0TB     80%(4.0TB)    4.9TB 106.1GB             Yes                   No
/projects/downscale-idf                    5.0TB     80%(4.0TB)    3.8TB   1.2TB              No                   No
/projects/hydrology/scratch0               1.0TB     80%(819.2GB)   95.9GB 928.1GB              No                   No
/projects/rci-scratch                      2.0TB     80%(1.6TB)    2.0TB  0Bytes             Yes                  Yes
/projects/dataportal                       1.0TB     80%(819.2GB)  775.4GB 248.6GB              No                   No
/modules                                   1.0TB     80%(819.2GB)   16.5GB 1007.5GB              No                   No
/projects                                 60.0TB     80%(48.0TB)   45.8TB  14.2TB              No                   No
/projects/bcsd                           600.0GB     80%(480.0GB)  321.3GB 278.7GB              No                   No
/projects/crmp                             1.0TB     80%(819.2GB)  386.8GB 637.2GB              No                   No
/data4/climate/CMIP5                      22.0TB     80%(17.6TB)  350.0GB  21.7TB              No                   No
/data4/climate/downscale/NARCCAP           5.0TB     80%(4.0TB)    4.2TB 863.4GB             Yes                   No
/projects/rci                              4.0TB     80%(3.2TB)    2.7TB   1.3TB              No                   No
/projects/MEOPAR                           7.0TB     80%(5.6TB)    7.4TB  0Bytes             Yes                  Yes
/data4/climate/hydrology                   1.0TB     80%(819.2GB)  858.7GB 165.3GB             Yes                   No
/projects/hydrology                        6.0TB     80%(4.8TB)    8.9TB  0Bytes             Yes                  Yes


Expected results:
                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/data4/climate                           120.0TB     80%(96.0TB)   95.7TB  24.3TB              No                   No
/data4/climate/CMIP5                      22.0TB     80%(17.6TB)  439.7GB  21.6TB              No                   No
/data4/climate/downscale/CMIP5            65.0TB     80%(52.0TB)   57.6TB   7.4TB             Yes                   No
/data4/climate/downscale/NARCCAP           5.0TB     80%(4.0TB)    4.2TB 863.4GB             Yes                   No
/data4/climate/hydrology                   1.0TB     80%(819.2GB)  858.7GB 165.3GB             Yes                   No
/data4/dem                                 1.0GB     80%(819.2MB)   0Bytes   1.0GB              No                   No
/data4/forestry                           50.0GB     80%(40.0GB)   46.0GB   4.0GB             Yes                   No
/data4/gis                                 2.2TB     80%(1.8TB)    2.1TB 108.5GB             Yes                   No
/data4/modperl                             1.0TB     80%(819.2GB)  948.3GB  75.7GB             Yes                   No
/data4/strays                             85.0GB     80%(68.0GB)   80.8GB   4.2GB             Yes                   No
/modules                                   1.0TB     80%(819.2GB)   16.5GB 1007.5GB              No                   No
/projects                                 60.0TB     80%(48.0TB)   45.8TB  14.2TB              No                   No
/projects/bcsd                           600.0GB     80%(480.0GB)  321.3GB 278.7GB              No                   No
/projects/CanSISE                         10.0TB     80%(8.0TB)    3.5TB   6.5TB              No                   No
/projects/crmp                             1.0TB     80%(819.2GB)  386.8GB 637.2GB              No                   No
/projects/dataportal                       1.0TB     80%(819.2GB)  775.4GB 248.6GB              No                   No
/projects/downscale-idf                    5.0TB     80%(4.0TB)    3.8TB   1.2TB              No                   No
/projects/downscale-idf-ec                 5.0TB     80%(4.0TB)    4.9TB 106.1GB             Yes                   No
/projects/hydrology                       10.0TB     80%(8.0TB)    8.9TB   1.1TB             Yes                   No
/projects/hydrology/archive0               5.0TB     80%(4.0TB)    4.7TB 282.2GB             Yes                   No
/projects/hydrology/scratch0               1.0TB     80%(819.2GB)   95.9GB 928.1GB              No                   No
/projects/MEOPAR                           7.0TB     80%(5.6TB)    7.4TB  0Bytes             Yes                  Yes
/projects/rci                              4.0TB     80%(3.2TB)    2.7TB   1.3TB              No                   No
/projects/rci-scratch                      2.0TB     80%(1.6TB)    2.0TB  0Bytes             Yes                  Yes

Additional info:

Why? Because when setting quotas on nested directories it is much more logical to immediately see the parent quota above the child quota when getting quota stats.

Comment 2 Vijay Bellur 2016-04-14 12:27:07 UTC
REVIEW: http://review.gluster.org/14000 (cli/quota: Sort the list output alphabetically by path) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Vijay Bellur 2016-04-14 12:56:00 UTC
REVIEW: http://review.gluster.org/14000 (cli/quota: Sort the list output alphabetically by path) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Vijay Bellur 2016-04-22 02:57:33 UTC
REVIEW: http://review.gluster.org/14000 (cli/quota: Sort the list output alphabetically by path) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 5 Vijay Bellur 2016-04-25 09:33:01 UTC
COMMIT: http://review.gluster.org/14000 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 760dfb6e8aebc44b419e8943e4e3895591097b8b
Author: vmallika <vmallika@redhat.com>
Date:   Thu Apr 14 17:51:19 2016 +0530

    cli/quota: Sort the list output alphabetically by path
    
    Change-Id: I0b124e119d167817be2ae3eb52ac6c80fc7db5d1
    BUG: 1320716
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/14000
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 6 Niels de Vos 2016-06-16 14:01:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.