Bug 1320964 - REST API: Can't set quota for DC (in v3 compatibility mode at least) - "No enum constant org.ovirt.engine.api.model.QuotaModeType.disabled" [NEEDINFO]
Summary: REST API: Can't set quota for DC (in v3 compatibility mode at least) - "No en...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.0.0-alpha
: ---
Assignee: Juan Hernández
QA Contact: Pavel Stehlik
URL:
Whiteboard:
: 1325677 (view as bug list)
Depends On:
Blocks: 1186388 1283499
TreeView+ depends on / blocked
 
Reported: 2016-03-24 11:20 UTC by Yaniv Kaul
Modified: 2016-04-11 11:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-27 06:54:45 UTC
oVirt Team: Infra
nsednev: needinfo? (oliel)
juan.hernandez: ovirt-4.0.0?
rule-engine: blocker?
rule-engine: planning_ack+
juan.hernandez: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 55230 0 master MERGED restapi: Use "fromValue" in V3 adapters 2016-03-24 19:31:55 UTC

Description Yaniv Kaul 2016-03-24 11:20:51 UTC
Description of problem:
Trying to add (via the Python SDK) a quota to a DC fails.
Server.log shows:
2016-03-24 05:04:05,623 ERROR [io.undertow.request] (default task-8) UT005023: Exception handling request to /ovirt-engine/api/v3/datacenters/adad955e-e414-4b28-9af5-cc8ee9ab8a82/quotas: java.lang.RuntimeExcepti
on: org.jboss.resteasy.spi.UnhandledException: java.lang.IllegalArgumentException: No enum constant org.ovirt.engine.api.model.QuotaModeType.disabled
        at io.undertow.servlet.spec.RequestDispatcherImpl.forwardImpl(RequestDispatcherImpl.java:217) [undertow-servlet-1.3.15.Final.jar:1.3.15.Final]
        at io.undertow.servlet.spec.RequestDispatcherImpl.forward(RequestDispatcherImpl.java:106) [undertow-servlet-1.3.15.Final.jar:1.3.15.Final]
        at org.ovirt.engine.api.restapi.invocation.VersionFilter.doFilter(VersionFilter.java:139) [restapi-jaxrs.jar:]
        at org.ovirt.engine.api.restapi.invocation.VersionFilter.doFilter(VersionFilter.java:68) [restapi-jaxrs.jar:]
        at io.undertow.servlet.core.ManagedFilter.doFilter(ManagedFilter.java:60) [undertow-servlet-1.3.15.Final.jar:1.3.15.Final]
        at io.undertow.servlet.handlers.FilterHandler$FilterChainImpl.doFilter(FilterHandler.java:131) [undertow-servlet-1.3.15.Final.jar:1.3.15.Final]
        at org.ovirt.engine.api.restapi.invocation.CurrentFilter.doFilter(CurrentFilter.java:83) [restapi-jaxrs.jar:]
        at org.ovirt.engine.api.restapi.invocation.CurrentFilter.doFilter(CurrentFilter.java:63) [restapi-jaxrs.jar:]
        at io.undertow.servlet.core.ManagedFilter.doFilter(ManagedFilter.java:60) [undertow-servlet-1.3.15.Final.jar:1.3.15.Final]
        at io.undertow.servlet.handlers.FilterHandler$FilterChainImpl.doFilter(FilterHandler.java:131) [undertow-servlet-1.3.15.Final.jar:1.3.15.Final]
        at org.ovirt.engine.core.aaa.filters.RestApiSessionMgmtFilter.doFilter(RestApiSessionMgmtFilter.java:81) [aaa.jar:]
        at io.undertow.servlet.core.ManagedFilter.doFilter(ManagedFilter.java:60) [undertow-servlet-1.3.15.Final.jar:1.3.15.Final]
        at io.undertow.servlet.handlers.FilterHandler$FilterChainImpl.doFilter(FilterHandler.java:131) [undertow-servlet-1.3.15.Final.jar:1.3.15.Final]
        at org.ovirt.engine.core.aaa.filters.EnforceAuthFilter.doFilter(EnforceAuthFilter.java:39) [aaa.jar:]


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2016-03-24 18:33:13 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Juan Hernández 2016-03-24 18:39:18 UTC
This regression was introduced by the recent change to use type safe enums in version 4 of the API. The proposed patch fixes it.

Comment 3 Yaniv Kaul 2016-03-27 06:54:45 UTC
Verified - fix is working.

Comment 4 Ori Liel 2016-04-11 08:09:11 UTC
*** Bug 1325677 has been marked as a duplicate of this bug. ***

Comment 5 Nikolai Sednev 2016-04-11 11:19:44 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1325677 <- In which build version should the fix appear for the first time? How can I proceed with the HE deployment?


Note You need to log in before you can comment on or make changes to this bug.