Bug 132146 - unix2dos doesn't preserve the file permissions
unix2dos doesn't preserve the file permissions
Status: CLOSED DUPLICATE of bug 91332
Product: Fedora
Classification: Fedora
Component: unix2dos (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-09 03:40 EDT by Péter, Soós
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Péter, Soós 2004-09-09 03:40:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; hu-HU; rv:1.7.2)
Gecko/20040803

Description of problem:
It seems like unix2dos doesn't preserve the file permissions (group
read/write):

$ ls -l proba.txt
-rw-rw-r--  1 sp sp 39 Sep  9 09:24 proba.txt
$ unix2dos proba.txt
unix2dos: converting file proba.txt to DOS format ...
$ ls -l proba.txt
-rw-------  1 sp sp 37 Sep  9 09:24 proba.txt


Version-Release number of selected component (if applicable):
dos2unix-3.1-17

How reproducible:
Always

Steps to Reproduce:
1. create a file with permissions 664
2. dos2unix it

    

Actual Results:  dos2unix doesn't preserve the file permissions

Expected Results:  dos2unix preserves the file permissions

Additional info:
Comment 1 Mike A. Harris 2004-09-26 05:05:30 EDT

*** This bug has been marked as a duplicate of 91332 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.