Bug 91332 - unix2dos doesn't preserve mode
Summary: unix2dos doesn't preserve mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: unix2dos
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
: 132146 (view as bug list)
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2003-05-21 15:15 UTC by hjl
Modified: 2007-04-18 16:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-20 00:35:34 UTC


Attachments (Terms of Use)
A patch to preserve mode (852 bytes, patch)
2003-05-21 15:16 UTC, hjl
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:195 low SHIPPED_LIVE dos2unix and unix2dos bug fix update 2005-05-19 04:00:00 UTC

Description hjl 2003-05-21 15:15:39 UTC
[hjl@gnu-d tmp]$ touch foo
[hjl@gnu-d tmp]$ chmod +x foo
[hjl@gnu-d tmp]$ ls -l foo
-rwx--x--x    1 hjl      hjl             0 May 21 08:16 foo
[hjl@gnu-d tmp]$ unix2dos foo
unix2dos: converting file foo to DOS format ...
[hjl@gnu-d tmp]$ ls -l foo
-rw-------    1 hjl      hjl             0 May 21 08:17 foo

Comment 1 hjl 2003-05-21 15:16:12 UTC
Created attachment 91861 [details]
A patch to preserve mode

Comment 2 Mike A. Harris 2004-09-26 09:05:37 UTC
*** Bug 132146 has been marked as a duplicate of this bug. ***

Comment 3 Tim Waugh 2004-10-11 13:25:07 UTC
Tried to send this upstream but it bounced.  Built as 2.2-23.

Comment 4 Mike A. Harris 2004-10-12 01:34:29 UTC
Tim:

Yeah, neither dos2unix and unix2dos seem to have an upstream
maintainer for several years now.  I guess the best thing to do
would be to gather all the patches in our bugzilla together,
gather debian/mandrake/suse/etc. packages, and put up a new
project on sourceforge or somewhere to pull all fixes into one
single place that everyone can then use.  Then each distribution
package maintainer can have write access to the sf repo and things
get fixed in one place.  ;)

Comment 5 Doncho Gunchev 2004-11-04 18:07:30 UTC
Seems to work for me.

Comment 6 Tim Powers 2005-05-20 00:35:34 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-195.html



Note You need to log in before you can comment on or make changes to this bug.