Bug 1321681 - RFE: [OSP15] Enable rabbitmq management plugin
Summary: RFE: [OSP15] Enable rabbitmq management plugin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M3
: 15.0 (Stein)
Assignee: Michele Baldessari
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks: 1732220 1736832 1743868
TreeView+ depends on / blocked
 
Reported: 2016-03-28 21:43 UTC by Marian Krcmarik
Modified: 2019-12-29 22:23 UTC (History)
24 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190701110422.889d4d4.el8ost
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1732220 1736832 (view as bug list)
Environment:
Last Closed: 2019-09-21 11:15:27 UTC
Target Upstream Version:
alink: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github voxpupuli puppet-rabbitmq pull 777 None closed Add support for enabled plugins config using enabled_plugins file 2020-03-06 07:17:41 UTC
OpenStack gerrit 636511 None MERGED Enable rabbitmq_management plugin 2020-03-06 07:17:41 UTC
Red Hat Product Errata RHEA-2019:2811 None None None 2019-09-21 11:16:34 UTC

Description Marian Krcmarik 2016-03-28 21:43:50 UTC
Description of problem:
rabbitmq server has a possibility to enable REST API of the service by allowing rabbitmq management plugin. The only way right now how to query and set rabbitmq cluster is through rabbitmqctl command line tool which output is erlang formatted. By enabling REST API, json formatted output could be got and easily parsable for automation purposes.

How to enable the management pluging:
1. Create a file in /etc/rabbitmq/enabled_plugins with content of:
[rabbitmq_management].
2. Make it rw for rabbitmq user.
3. Edit rabbitmq_management section in /etc/rabbitmq/rabbitmq.config to look like:
{rabbitmq_management, [
  {listener, [{port, 15672}, {ip, "127.0.0.1"}]}
]}

- So for now It's allowed only on localhost, possibly It could be allowed on internal interface used for rabbitmq communication.

Comment 3 Michele Baldessari 2016-04-06 05:24:28 UTC
So the puppet-rabbitmq does support the enabling of the management plugin via the
$admin_enable class parameter. The issue is that it only works when:
$admin_enable and $service_manage are true. Since we manage rabbitmq with
pacemaker we do set $service_manage to false, so this approach won't work.

The simplest thing will be to wait for the puppet-pacemaker changes to
manage all pacemaker services via puppet. I need to think about this one a bit more.

Comment 4 Mike Burns 2016-04-07 21:36:02 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 5 Michele Baldessari 2016-09-29 20:21:51 UTC
So if I tweak the puppet-rabbitmq module to not require service_manage to be true (we are using pacemaker so it is always false), but during the deployment I get an error because the module insists on verifying it is up:
Error: curl -k --noproxy 172.16.2.6 --retry 30 --retry-delay 6 -f -L -o /var/lib/rabbitmq/rabbitmqadmin http://guest:DRzBkenNTDk9ybGRZUktQn9y4@172.16.2.6:15672/cli/rabbitmqadmin returned 7 instead of one of [0]\u001b[0m\n\u001b[1;31mError: /Stage[main]/Rabbitmq::Install::Rabbitmqadmin/Staging::File[rabbitmqadmin]/Exec[/var/lib/rabbitmq/rabbitmqadmin]/returns: change from notrun to 0 failed: curl -k --noproxy 172.16.2.6 --retry 30 --retry-delay 6 -f -L -o /var/lib/rabbitmq/rabbitmqadmin http://guest:DRzBkenNTDk9ybGRZUktQn9y4@172.16.2.6:15672/cli/rabbitmqadmin returned 7 instead of one of [0]\u001b[0m\n\u001b[1;31mWarning: /Stage[main]/Rabbitmq::Install::Rabbitmqadmin/File[/usr/local/bin/rabbitmqadmin]: Skipping because of failed dependencies\u001b[0m\n"

So the changes to the puppet module might need to be a bit more involved

Comment 6 Rob Young 2016-10-11 19:35:23 UTC
@michele should we move this out to OSP 11?

Comment 10 Red Hat Bugzilla Rules Engine 2017-06-04 02:43:56 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 11 Andrew Beekhof 2018-05-21 06:31:24 UTC
Michele: any plans for this or is it no longer needed?

Comment 28 Luca Miccini 2019-09-18 12:41:20 UTC
verified with RHOS_TRUNK-15.0-RHEL-8-20190913.n.3.

Comment 30 errata-xmlrpc 2019-09-21 11:15:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.