Bug 1321858 - libcgroup dependency error when installing node in ose-2.2
Summary: libcgroup dependency error when installing node in ose-2.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 2.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Rory Thrasher
QA Contact: Ma xiaoqiang
URL:
Whiteboard:
: 1322680 (view as bug list)
Depends On:
Blocks: 1358938
TreeView+ depends on / blocked
 
Reported: 2016-03-29 09:28 UTC by Gaoyun Pei
Modified: 2019-10-10 11:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1358938 (view as bug list)
Environment:
Last Closed: 2016-04-07 15:22:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1235353 None None None 2016-04-06 04:59:25 UTC
Red Hat Product Errata RHBA-2016:0608 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 2.2 libcgroup bug fix update 2016-04-07 19:21:36 UTC

Description Gaoyun Pei 2016-03-29 09:28:00 UTC
Description of problem:
Installation would abort when installing node packages due to libcgroup dependency error.
The latest libcgroup package in rhel-6-server-rpms repo is libcgroup-0.40.rc1-17.el6_7.x86_64 now, but we only have libcgroup-pam-0.40.rc1-16.el6.x86_64.rpm in the latest 2.2 puddle.

Version-Release number of selected component (if applicable):
OpenShiftEnterpriseErrata/2.2/2016-03-11.1

How reproducible:
Always

Steps to Reproduce:
1.[root@dhcp-128-178 ~]# yum install rubygem-openshift-origin-node

Actual results:
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for libcgroup which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libcgroup of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libcgroup.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of libcgroup installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of libcgroup installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: libcgroup-0.40.rc1-16.el6.i686 != libcgroup-0.40.rc1-17.el6_7.x86_64


Expected results:
Should no error happened during installation

Additional info:

Comment 3 Timothy Williams 2016-04-04 16:18:37 UTC
*** Bug 1322680 has been marked as a duplicate of this bug. ***

Comment 5 Gaoyun Pei 2016-04-06 04:52:15 UTC
Verify this bug with latest puddle 2.2/2016-03-29.1

libcgroup-pam-0.40.rc1-17.el6_7.x86_64.rpm was added into latest OSE repo, so no libcgroup dependency error encountered during a clean install. After installation, check the related packages on node:
[root@node1 ~]# rpm -qa|grep libcgroup
libcgroup-0.40.rc1-17.el6_7.x86_64
libcgroup-pam-0.40.rc1-17.el6_7.x86_64

And in an ose-2.2.8 env, the original libcgroup package was:
[root@node1 ~]# rpm -qa|grep libcgroup
libcgroup-pam-0.40.rc1-16.el6.x86_64
libcgroup-0.40.rc1-16.el6.x86_64

Then update the packages after 2.2/2016-03-29.1 puddle repo and latest rhel-6-server-rpms repo configured on the host.
[root@broker ~]# yum update 
...
 libcgroup                                        x86_64                      0.40.rc1-17.el6_7                              rhel6                                     129 k
 libcgroup-pam                                    x86_64                      0.40.rc1-17.el6_7                              openshift_node_extra                       26 k
...
Update is successful.

Comment 7 errata-xmlrpc 2016-04-07 15:22:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0608.html


Note You need to log in before you can comment on or make changes to this bug.