Bug 1322680 - "Protected multilib versions error", during upgrade/installation of OSE 2.2.9-1.el6op
Summary: "Protected multilib versions error", during upgrade/installation of OSE 2.2.9...
Keywords:
Status: CLOSED DUPLICATE of bug 1321858
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 2.2.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: Jason DeTiberus
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-31 06:10 UTC by Kenjiro Nakayama
Modified: 2019-10-10 11:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-04 16:18:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1152315 None None None 2016-03-31 06:12:17 UTC

Description Kenjiro Nakayama 2016-03-31 06:10:31 UTC
Description of problem:
===
When I try to update with yum update, I hit the error "Protected multilib versions error".


How reproducible:
===
Before update my environment is ...

[root@node1 ~]# cat /etc/openshift-enterprise-release 
OpenShift Enterprise 2.1.5
[root@node1 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.5 (Santiago)


Steps to Reproduce:
===
# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.7 (Santiago)
# cat /etc/openshift-enterprise-release 
OpenShift Enterprise 2.2.6


1. Just `#yum update` with above environment.


Actual results:
===
~~~
[root@node1 ~]# yum update

 ....
---> Package openshift-enterprise-release.noarch 0:2.2.6-1.el6op will be updated
---> Package openshift-enterprise-release.noarch 0:2.2.9-1.el6op will be an update

  ...
  
jb-eap-6-for-rhel-6-server-rpms/filelists_db                                                                                   | 4.3 MB     00:01     
jb-ews-2-for-rhel-6-server-rpms/filelists_db                                                                                   | 179 kB     00:00     
rhel-6-server-ose-2.2-jbosseap-rpms/filelists_db                                                                               | 7.1 kB     00:00     
rhel-6-server-ose-2.2-node-rpms/filelists_db                                                                                   | 369 kB     00:00     
rhel-6-server-rpms/filelists_db                                                                                                |  20 MB     00:03     
rhel-server-rhscl-6-rpms/filelists_db                                                                                          | 6.5 MB     00:01     
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-504.el6 will be erased
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for libcgroup which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libcgroup of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libcgroup.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of libcgroup installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of libcgroup installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: libcgroup-0.40.rc1-16.el6.i686 != libcgroup-0.40.rc1-17.el6_7.x86_64
~~~


Expected results:
===

- Update without error.

Comment 1 Kenjiro Nakayama 2016-03-31 06:11:13 UTC
[root@ose2-node1 ~]# yum repolist
Loaded plugins: priorities, product-id, refresh-packagekit, security, subscription-manager
65 packages excluded due to repository priority protections
repo id                                             repo name                                                                               status
jb-eap-6-for-rhel-6-server-rpms                     JBoss Enterprise Application Platform 6 (RHEL 6 Server) (RPMs)                            2,664+32
jb-ews-2-for-rhel-6-server-rpms                     JBoss Enterprise Web Server 2 (RHEL 6 Server) (RPMs)                                        314+35
rhel-6-server-ose-2.2-jbosseap-rpms                 Red Hat OpenShift Enterprise 2.2 JBoss EAP add-on (RPMs)                                        12
rhel-6-server-ose-2.2-node-rpms                     Red Hat OpenShift Enterprise 2.2 Application Node (RPMs)                                     502+1
rhel-6-server-rpms                                  Red Hat Enterprise Linux 6 Server (RPMs)                                                16,646+143
rhel-server-rhscl-6-rpms                            Red Hat Software Collections RPMs for Red Hat Enterprise Linux 6 Server                    5,234+1
repolist: 25,372

Comment 2 Timothy Williams 2016-04-04 16:18:37 UTC
This is a known issue and is being tracked in https://bugzilla.redhat.com/show_bug.cgi?id=1321858

*** This bug has been marked as a duplicate of bug 1321858 ***


Note You need to log in before you can comment on or make changes to this bug.