Bug 1322572 - Version bump to 1.055 causes warnings on el6
Summary: Version bump to 1.055 causes warnings on el6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: perl-Net-SSLGlue
Version: el6
Hardware: noarch
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Denis Fateyev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-30 18:52 UTC by Brian Hinz
Modified: 2016-04-24 09:28 UTC (History)
3 users (show)

Fixed In Version: perl-Net-SSLGlue-1.057-1.el6 perl-Net-SSLGlue-1.057-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-19 00:30:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1312492 None None None 2016-03-30 18:52:52 UTC

Description Brian Hinz 2016-03-30 18:52:52 UTC
Description of problem:

The version bump from 0.8 to 1.055 causes the following warning to be issued on el6:

Use of uninitialized value $LWP::Protocol::https::VERSION in numeric ge (>=) at /usr/share/perl5/vendor_perl/Net/SSLGlue/LWP.pm line 14.

because VERSION is not defined in the 5.833 version of LWP::Protocol::https.pm that ships with perl-libwww-perl on el6.

Version-Release number of selected component (if applicable):

1.055-3.el6

How reproducible:

100%

Steps to Reproduce:

perl -e 'use Net::SSLGlue::LWP;'

Actual results:

Warning issued


Expected results:

No warnings issued

Additional info:

It looks like it would be a rather trivial patch to simply add a check whether VERSION is defined to the conditional.  I've only looked at it briefly, but it looks as though functionality is not impacted.

Comment 1 Denis Fateyev 2016-03-30 20:18:16 UTC
Although it's not critical, I'll check and fix this warning soon.
Thanks for the report.

Comment 2 Denis Fateyev 2016-03-31 18:16:09 UTC
$ cat perl-Net-SSLGlue-https-version.patch 
--- lib/Net/SSLGlue/LWP.pm	2015-04-28 12:23:10.000000000 +0600
+++ lib/Net/SSLGlue/LWP.pm	2016-03-31 23:46:12.947143916 +0600
@@ -11,7 +11,8 @@
 my $use_existent;
 BEGIN {
     require LWP::Protocol::https;
-    $use_existent = $LWP::Protocol::https::VERSION >= 6.06
+    $use_existent = defined($LWP::Protocol::https::VERSION)
+	&& $LWP::Protocol::https::VERSION >= 6.06
 	&& $LWP::UserAgent::VERSION >= 6.06;
     if ($use_existent) {
 	my $oc = $Net::HTTPS::SSL_SOCKET_CLASS ||

Comment 3 Fedora Update System 2016-03-31 18:23:05 UTC
perl-Net-SSLGlue-1.055-4.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d6ea31e69d

Comment 4 Fedora Update System 2016-04-01 01:20:35 UTC
perl-Net-SSLGlue-1.055-4.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d6ea31e69d

Comment 5 Brian Hinz 2016-04-01 21:39:49 UTC
Just confirming that your patch does indeed silence the warnings.  Thanks for the quick resolution.

Comment 6 Fedora Update System 2016-04-06 21:45:34 UTC
perl-Net-SSLGlue-1.057-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-245d3bd7d6

Comment 7 Fedora Update System 2016-04-06 21:45:45 UTC
perl-Net-SSLGlue-1.057-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-015f19528b

Comment 8 Denis Fateyev 2016-04-06 21:49:56 UTC

*** This bug has been marked as a duplicate of bug 1324639 ***

Comment 9 Fedora Update System 2016-04-07 20:20:47 UTC
perl-Net-SSLGlue-1.057-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-245d3bd7d6

Comment 10 Fedora Update System 2016-04-07 20:24:41 UTC
perl-Net-SSLGlue-1.057-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-015f19528b

Comment 11 Fedora Update System 2016-04-19 00:29:58 UTC
perl-Net-SSLGlue-1.057-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-04-24 09:28:05 UTC
perl-Net-SSLGlue-1.057-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.