Bug 1322695 - TIER : Wrong message display.On detach tier success the message reflects Tier command failed.
Summary: TIER : Wrong message display.On detach tier success the message reflects Tier...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: RHGS 3.1.3
Assignee: hari gowtham
QA Contact: krishnaram Karthick
URL:
Whiteboard:
Depends On:
Blocks: 1311817 1324439 1328410 1337908
TreeView+ depends on / blocked
 
Reported: 2016-03-31 07:02 UTC by Vivek Das
Modified: 2016-09-17 15:36 UTC (History)
15 users (show)

Fixed In Version: glusterfs-3.7.9-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1324439 (view as bug list)
Environment:
Last Closed: 2016-06-23 05:14:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1240 0 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 Update 3 2016-06-23 08:51:28 UTC

Description Vivek Das 2016-03-31 07:02:59 UTC
Description of problem:

After successfully detach tier command completion, the message reflecting on the screen is "Tier command failed".

Version-Release number of selected component (if applicable):
samba-4.4.0-1.el7rhgs.x86_64
glusterfs-3.7.9-1.el7rhgs.x86_64

How reproducible:

Always

Steps to Reproduce:
1.Mount tier volume on multiple windows client (cold tier : Distributed-Disperse | 2 x (8 + 4) | Hot Tier Type : Distributed-Replicate 4 x 2 = 8)
2.gluster volume tier harharmahadev detach start
3.gluster volume tier harharmahadev detach status (keep checking till completion)

Actual results:
Tier command failed

Expected results:
Appropriate success message expected

Additional info:

Comment 9 krishnaram Karthick 2016-05-12 04:39:15 UTC
Moving this bug back to assigned to address the concerns in comment#7.

Comment 13 hari gowtham 2016-05-20 07:42:14 UTC
The Warning message will appear if any node is down, expect for the last node.
This is another issue with the design and cannot be fixed for 3.1.3

Comment 15 Milind Changire 2016-05-23 08:26:50 UTC
BZ added to RHEL 6 Errata for RHGS 3.1.3 ... moving to ON_QA

Comment 21 errata-xmlrpc 2016-06-23 05:14:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240


Note You need to log in before you can comment on or make changes to this bug.