Bug 1324439 - SAMBA+TIER : Wrong message display.On detach tier success the message reflects Tier command failed.
Summary: SAMBA+TIER : Wrong message display.On detach tier success the message reflect...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: hari gowtham
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1322695
Blocks: 1328410 1337908
TreeView+ depends on / blocked
 
Reported: 2016-04-06 10:44 UTC by hari gowtham
Modified: 2016-06-16 14:03 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1322695
: 1328410 (view as bug list)
Environment:
Last Closed: 2016-06-16 14:03:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-06 10:54:53 UTC
REVIEW: http://review.gluster.org/13918 (Tier: tier command fails message when any node is down) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 2 Vijay Bellur 2016-04-12 05:54:46 UTC
REVIEW: http://review.gluster.org/13918 (Tier: tier command fails message when any node is down) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 3 Vijay Bellur 2016-04-12 07:51:37 UTC
REVIEW: http://review.gluster.org/13918 (Tier: tier command fails message when any node is down) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 4 Vijay Bellur 2016-04-13 06:03:51 UTC
REVIEW: http://review.gluster.org/13918 (Tier: tier command fails message when any node is down) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 5 Vijay Bellur 2016-04-13 14:16:47 UTC
REVIEW: http://review.gluster.org/13918 (Tier: tier command fails message when any node is down) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 6 Vijay Bellur 2016-04-14 08:29:11 UTC
REVIEW: http://review.gluster.org/13918 (Tier: tier command fails message when any node is down) posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 7 Vijay Bellur 2016-04-15 10:42:27 UTC
REVIEW: http://review.gluster.org/13918 (Tier: tier command fails message when any node is down) posted (#7) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 8 Vijay Bellur 2016-04-18 07:07:06 UTC
REVIEW: http://review.gluster.org/13918 (Tier: tier command fails message when any node is down) posted (#8) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 9 Vijay Bellur 2016-04-19 10:13:25 UTC
COMMIT: http://review.gluster.org/13918 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 690715bb3e341f673a71d1dc8b80bb35aa29c75d
Author: hari <hgowtham@redhat.com>
Date:   Wed Apr 6 16:16:47 2016 +0530

    Tier: tier command fails message when any node is down
    
    PROBLEM: the dict doesn't get set on the node if its down.
    so while printing the output on cli we get a ENOENT
    which ends in a tier command failed.
    
    FIX: this patch skips the node that wasn't available
    and carrys on with the next node for both tier status
    and tier detach status.
    
    Change-Id: I718a034b18b109748ec67f3ace56540c50650d23
    BUG: 1324439
    Signed-off-by: hari <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/13918
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 10 Vijay Bellur 2016-05-16 05:31:34 UTC
REVIEW: http://review.gluster.org/14347 (tier/cli : printing node unreachable instead of skipping the node) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 11 Vijay Bellur 2016-05-16 10:52:15 UTC
REVIEW: http://review.gluster.org/14347 (tier/cli : printing a warning instead of skipping the node) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 12 Vijay Bellur 2016-05-17 05:19:42 UTC
REVIEW: http://review.gluster.org/14347 (tier/cli : printing a warning instead of skipping the node) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 13 Vijay Bellur 2016-05-18 08:37:29 UTC
REVIEW: http://review.gluster.org/14347 (tier/cli : printing a warning instead of skipping the node) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 14 Vijay Bellur 2016-05-18 09:04:30 UTC
REVIEW: http://review.gluster.org/14347 (tier/cli : printing a warning instead of skipping the node) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 15 Vijay Bellur 2016-05-20 07:47:54 UTC
REVIEW: http://review.gluster.org/14347 (tier/cli : printing a warning instead of skipping the node) posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 16 Vijay Bellur 2016-05-20 08:31:20 UTC
REVIEW: http://review.gluster.org/14347 (tier/cli : printing a warning instead of skipping the node) posted (#7) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 17 Vijay Bellur 2016-05-20 08:37:32 UTC
REVIEW: http://review.gluster.org/14347 (tier/cli : printing a warning instead of skipping the node) posted (#8) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 18 Vijay Bellur 2016-05-20 14:25:41 UTC
COMMIT: http://review.gluster.org/14347 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit d5e67cd2b2d60166f16337e4441fa50a9e488094
Author: hari gowtham <hgowtham@redhat.com>
Date:   Mon May 16 10:55:17 2016 +0530

    tier/cli : printing a warning instead of skipping the node
    
    Problem: skipping the status of the nodes down creates confusion
    to the user as one might see the status as completed for all nodes
    and while performing detach commit, the operation will fail as the
    node is down
    
    Fix: Display a warning message
    
    Note: When the last node is down (as per the peer list) then
    warning message can't be displayed as the total number of peers
    participating in the transaction is considered to be the total count.
    
    Change-Id: Ib7afbd1b26df3378e4d537db06f41f5c105ad86e
    BUG: 1324439
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/14347
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 19 Niels de Vos 2016-06-16 14:03:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.