Bug 132290 - gnucash won't start
gnucash won't start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: umb-scheme (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
: 132251 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-10 12:42 EDT by Tim Waugh
Modified: 2013-07-02 19:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: 3.2-35
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 03:26:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-09-10 12:42:38 EDT
Description of problem:
Since updating to this package Gnucash no longer starts.  It says:

ERROR: In procedure open-file:
ERROR: No such file or directory: "/usr/share/guile/slib/mklibcat"

Version-Release number of selected component (if applicable):
umb-scheme-3.2-34

How reproducible:
100%

Steps to Reproduce:
1. Start gnucash.

umb-scheme-3.2-33 works fine.
Comment 1 Bill Nottingham 2004-09-10 12:52:41 EDT
See also:

http://bugzilla.gnome.org/show_bug.cgi?id=128701
Comment 2 Bill Nottingham 2004-09-10 15:17:38 EDT
*** Bug 132251 has been marked as a duplicate of this bug. ***
Comment 3 Derek Atkins 2004-09-12 15:53:26 EDT
FYI, this was mostly fixed in gnucash 1.8.9 and one last compilation
problem was fixed on 2004-05-05.  This _particular_ problem is more
that the slib catalog file needs to be rebuilt, which required
effectively running gnucash as root once.
Comment 4 Ralf Ertzinger 2004-09-13 07:32:09 EDT
Running gnucash as root once fixes the problem for me.
Comment 5 Bill Nottingham 2004-09-13 12:21:21 EDT
Yeah, but that's not really a user-friendly solution. There should be
some way to rebuild the catalog file at build time.
Comment 6 Tim Waugh 2004-09-13 12:47:30 EDT
umb-scheme-3.2-35 fixes the problem for me.
Comment 7 Jindrich Novy 2004-09-14 03:26:00 EDT
Hello Tim, I regenerated the slibcat to be friendly with slib 3a1 and
it works fine also for me. Closing this.

Ralf, running gnucash as root solves the situation too, because guile
tries to regenerate slibcat form umb-scheme if it's missing, but
nonroot user has no chance to launch gnucash as guile cannot write to
/usr/share/guile...

HTH,
Jindrich

Note You need to log in before you can comment on or make changes to this bug.