Bug 1323283 - realtime profile: disable timer migration
Summary: realtime profile: disable timer migration
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Tereza Cerna
Jiri Herrmann
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 1273048 1360800
TreeView+ depends on / blocked
 
Reported: 2016-04-01 17:28 UTC by Luiz Capitulino
Modified: 2016-11-04 07:27 UTC (History)
5 users (show)

(edit)
Timer migration for realtime Tuned profile has been disabled

Previously, the realtime Tuned profile that is included in the _tuned-profiles-realtime_ package set the value of the `kernel.timer_migration` variable to 1. As a consequence, realtime applications could be negatively affected. This update disables the timer migration in the realtime profile.
Clone Of:
: 1360800 (view as bug list)
(edit)
Last Closed: 2016-11-04 07:27:19 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2479 normal SHIPPED_LIVE tuned bug fix and enhancement update 2016-11-03 14:08:42 UTC

Description Luiz Capitulino 2016-04-01 17:28:38 UTC
Description of problem:

It was found during code review that the kernel always try to migrate timers away from idle CPUs to busy CPUs. Real-time CPUs running dpdk polling threads for example, are busy so they are a great candidate to receive timers from idle CPUs (see get_nohz_timer_target() in the kernel sources).

It is not clear how this problem can affect real-time applications and KVM-RT. However, for real-time and high-performance the best thing is for a timer to always fire in the CPU where it was created.

Version-Release number of selected component (if applicable): tuned-profiles-realtime-2.5.1-6.el7.noarch

Comment 2 Luiz Capitulino 2016-04-04 14:45:30 UTC
Thanks a lot Jaroslav. I'll let you handle this for RHEL7.3 and later for RHEL7.2-z. But no rush, it's not an urgent issue.

Comment 9 Tereza Cerna 2016-08-22 12:43:24 UTC
==============================================
Verified in:
    tuned-2.7.1-2.el7.noarch
    tuned-profiles-realtime-2.7.1-2.el7.noarch
PASS
==============================================

# grep timer /usr/lib/tuned/realtime/tuned.conf 
kernel.timer_migration = 0
# sysctl kernel.timer_migration
kernel.timer_migration = 1
# tuned-adm profile realtime
# sysctl kernel.timer_migration
kernel.timer_migration = 0

==============================================
Reproduced in:
    tuned-2.5.1-1.el7.noarch
    tuned-profiles-realtime-2.5.1-1.el7.noarch
FAIL
==============================================

# grep timer /usr/lib/tuned/realtime/tuned.conf 
# sysctl kernel.timer_migration
kernel.timer_migration = 1
# tuned-adm profile realtime
# sysctl kernel.timer_migration
kernel.timer_migration = 1

Comment 11 errata-xmlrpc 2016-11-04 07:27:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2479.html


Note You need to log in before you can comment on or make changes to this bug.