RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1360800 - realtime profile: disable timer migration
Summary: realtime profile: disable timer migration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Tereza Cerna
URL:
Whiteboard:
Depends On: 1323283
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 14:00 UTC by Jan Kurik
Modified: 2016-09-15 08:00 UTC (History)
7 users (show)

Fixed In Version: tuned-2.5.1-4.el7_2.5
Doc Type: Bug Fix
Doc Text:
Previously, the realtime tuned profile that is included in the tuned-profiles-realtime package set the value of the kernel.timer_migration variable to 1. As a consequence, realtime applications could be negatively affected. This update disables the timer migration in the realtime profile.
Clone Of: 1323283
Environment:
Last Closed: 2016-09-15 08:00:22 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1848 0 normal SHIPPED_LIVE tuned bug fix update 2016-09-15 11:34:59 UTC

Description Jan Kurik 2016-07-27 14:00:53 UTC
This bug has been copied from bug #1323283 and has been proposed
to be backported to 7.2 z-stream (EUS).

Comment 4 Tereza Cerna 2016-08-22 12:44:18 UTC
==================================================
Verified in:
    tuned-2.5.1-4.el7_2.5.noarch
    tuned-profiles-realtime-2.5.1-4.el7_2.5.noarch
PASS
==================================================

# grep timer /usr/lib/tuned/realtime/tuned.conf 
kernel.timer_migration = 0
# sysctl kernel.timer_migration
kernel.timer_migration = 1
# tuned-adm profile realtime
# sysctl kernel.timer_migration
kernel.timer_migration = 0

==============================================
Reproduced in:
    tuned-2.5.1-1.el7.noarch
    tuned-profiles-realtime-2.5.1-1.el7.noarch
FAIL
==============================================

# grep timer /usr/lib/tuned/realtime/tuned.conf 
# sysctl kernel.timer_migration
kernel.timer_migration = 1
# tuned-adm profile realtime
# sysctl kernel.timer_migration
kernel.timer_migration = 1

Comment 6 errata-xmlrpc 2016-09-15 08:00:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1848.html


Note You need to log in before you can comment on or make changes to this bug.