Bug 1323360 - quota/cli: quota list with path not working when limit is not set
Summary: quota/cli: quota list with path not working when limit is not set
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Manikandan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1323490 1324053
TreeView+ depends on / blocked
 
Reported: 2016-04-02 03:51 UTC by Vijaikumar Mallikarjuna
Modified: 2016-06-16 14:02 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1323490 1324053 (view as bug list)
Environment:
Last Closed: 2016-06-16 14:02:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijaikumar Mallikarjuna 2016-04-02 03:51:00 UTC
When a quota limit is not set, 'quota list <path>' should still display the usage when a path parameter is specified.

# gluster volume quota vol1 list /
quota: No quota configured on volume vol1

# g;uster volume quota vol1 list-objects /
quota: No inode quota configured on volume vol1


We have specified a path '/' in quota list command and we are getting error 'No quota configured'

Expected result:
# gluster volume quota vol1 list-objects /
                  Path                   Hard-limit   Soft-limit      Files       Dirs     Available  Soft-limit exceeded? Hard-limit exceeded?
-----------------------------------------------------------------------------------------------------------------------------------------------
/                                              N/A       N/A          1          3         N/A             N/A                  N/A


# gluster volume quota vol1 list /
                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/                                           N/A        N/A          1.0MB       N/A             N/A                N/A

Comment 1 Vijaikumar Mallikarjuna 2016-04-02 03:53:58 UTC
Here is the test-case:
1) create volume
2) enable quota, but do not set any limits
3) create some files
4) execute quota list with path specified at the end
   #gluster volume quota vol1 list /
   #gluster volume quota vol1 list-objects /

Comment 2 Vijay Bellur 2016-04-02 03:57:06 UTC
REVIEW: http://review.gluster.org/13893 (quota/cli: display quota usage on path when limit not set) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Vijay Bellur 2016-04-05 12:23:33 UTC
COMMIT: http://review.gluster.org/13893 committed in master by Vijaikumar Mallikarjuna (vmallika@redhat.com) 
------
commit b198cdd6a47a964a102e8e96dc0de34cd19c2fd5
Author: vmallika <vmallika@redhat.com>
Date:   Sat Apr 2 09:20:45 2016 +0530

    quota/cli: display quota usage on path when limit not set
    
    When a quota limit is not set, 'quota list <path>' should still display
    the usage when a path parameter is specified.
    
    Change-Id: Ida12d9c5e348fbd98db4d68d9324c623cbdd3dea
    BUG: 1323360
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13893
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>

Comment 6 Niels de Vos 2016-06-16 14:02:34 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.