Bug 1323490 - quota/cli: quota list with path not working when limit is not set
Summary: quota/cli: quota list with path not working when limit is not set
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.7.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On: 1323360 1324053
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-03 15:09 UTC by Vijaikumar Mallikarjuna
Modified: 2016-05-11 22:48 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.11
Doc Type: Bug Fix
Doc Text:
Clone Of: 1323360
Environment:
Last Closed: 2016-04-19 07:13:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijaikumar Mallikarjuna 2016-04-03 15:09:53 UTC
+++ This bug was initially created as a clone of Bug #1323360 +++

When a quota limit is not set, 'quota list <path>' should still display the usage when a path parameter is specified.

# gluster volume quota vol1 list /
quota: No quota configured on volume vol1

# g;uster volume quota vol1 list-objects /
quota: No inode quota configured on volume vol1


We have specified a path '/' in quota list command and we are getting error 'No quota configured'

Expected result:
# gluster volume quota vol1 list-objects /
                  Path                   Hard-limit   Soft-limit      Files       Dirs     Available  Soft-limit exceeded? Hard-limit exceeded?
-----------------------------------------------------------------------------------------------------------------------------------------------
/                                              N/A       N/A          1          3         N/A             N/A                  N/A


# gluster volume quota vol1 list /
                  Path                   Hard-limit  Soft-limit      Used  Available  Soft-limit exceeded? Hard-limit exceeded?
-------------------------------------------------------------------------------------------------------------------------------
/                                           N/A        N/A          1.0MB       N/A             N/A                N/A

--- Additional comment from Vijaikumar Mallikarjuna on 2016-04-01 23:53:58 EDT ---

Here is the test-case:
1) create volume
2) enable quota, but do not set any limits
3) create some files
4) execute quota list with path specified at the end
   #gluster volume quota vol1 list /
   #gluster volume quota vol1 list-objects /

--- Additional comment from Vijay Bellur on 2016-04-01 23:57:06 EDT ---

REVIEW: http://review.gluster.org/13893 (quota/cli: display quota usage on path when limit not set) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 1 Vijay Bellur 2016-04-03 15:11:31 UTC
REVIEW: http://review.gluster.org/13895 (quota/cli: display quota usage on path when limit not set) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Vijay Bellur 2016-04-05 12:27:29 UTC
COMMIT: http://review.gluster.org/13895 committed in release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com) 
------
commit fcca19e8a24751a3a966c7c20a52da89928161e4
Author: vmallika <vmallika@redhat.com>
Date:   Sat Apr 2 09:20:45 2016 +0530

    quota/cli: display quota usage on path when limit not set
    
    This is a backport of http://review.gluster.org/#/c/13893/
    
    When a quota limit is not set, 'quota list <path>' should still display
    the usage when a path parameter is specified.
    
    > Change-Id: Ida12d9c5e348fbd98db4d68d9324c623cbdd3dea
    > BUG: 1323360
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I51cf46faffb324d2632dfde4264cd95d2da22479
    BUG: 1323490
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13895
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>

Comment 3 Kaushal 2016-04-19 07:13:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.11, please open a new bug report.

glusterfs-3.7.11 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026321.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.