Bug 1323504 - Syncing repostitory results in WARNING state (orange) with error
Summary: Syncing repostitory results in WARNING state (orange) with error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-03 18:35 UTC by Mike McCune
Modified: 2019-09-26 16:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:30:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman/production.log (7.54 KB, text/plain)
2016-04-08 21:52 UTC, Roman Plevka
no flags Details
grep pulp /var/log/messages (11.79 KB, text/plain)
2016-04-08 21:53 UTC, Roman Plevka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Mike McCune 2016-04-03 18:35:43 UTC
1) Sync custom http yum repo 
2) notice error at end:

 Errors:

undefined method `import_applicability' for #<Katello::System:0x0000001027b130>

 Error:

NoMethodError

undefined method `import_applicability' for #<Katello::System:0x0000001027b130>

Comment 2 Brad Buckingham 2016-04-04 13:50:34 UTC
The logic where this error is occurring went through several changes as part of bug 1244704.  So far, I have not been able to reproduce the error on the upstream.

Comment 3 Mike McCune 2016-04-04 22:37:09 UTC
Lets test this again once 1244704 is ON_QA

Comment 4 Roman Plevka 2016-04-08 12:43:04 UTC
FAILED QA:
on snap7.0

Sync still finishes with Warning. now with ISE (500).
according to logs (attached) pulp reports an unhandled exception.

- All i did to reproduce this was creating a custom yum repo and syncing it against URL:
http://omaciel.fedorapeople.org/fakerepo02/
- All other repository settings were left to defaults

Comment 5 Brad Buckingham 2016-04-08 13:35:13 UTC
Note: the error reported in comment 4 is entirely different from the original.  The original error is coming from the application code; however, the new one appears to be coming from pulp.  The new issue is documented in bug 1325339.

Comment 6 Roman Plevka 2016-04-08 21:52:03 UTC
(In reply to Brad Buckingham from comment #5)
> Note: the error reported in comment 4 is entirely different from the
> original.  The original error is coming from the application code; however,
> the new one appears to be coming from pulp.  The new issue is documented in
> bug 1325339.

you're right. Verification was just blocked by 1325339.

No longer blocked in Snap 7.1

VERIFIED
No import errors anymore.
(see attachments for foreman/product.log and pulp syslog messages)

Comment 7 Roman Plevka 2016-04-08 21:52:32 UTC
Created attachment 1145280 [details]
foreman/production.log

Comment 8 Roman Plevka 2016-04-08 21:53:04 UTC
Created attachment 1145281 [details]
grep pulp /var/log/messages

Comment 10 errata-xmlrpc 2016-07-27 09:30:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.