Bug 1323509 - Unable to create custom yum repo - Runtime error - zero length field name in format
Summary: Unable to create custom yum repo - Runtime error - zero length field name in ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
: 1323687 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-03 19:08 UTC by Roman Plevka
Modified: 2019-09-26 16:21 UTC (History)
9 users (show)

Fixed In Version: pulp-2.8.1.2-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:30:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman/production.log traceback (32.19 KB, text/plain)
2016-04-03 19:25 UTC, Roman Plevka
no flags Details
/var/log/messages error during repo create (9.88 KB, text/plain)
2016-04-04 15:33 UTC, Brad Buckingham
no flags Details


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 1809 High CLOSED - CURRENTRELEASE python 2.6 incompatibility during set_importer 2016-05-17 20:00:53 UTC
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Roman Plevka 2016-04-03 19:08:41 UTC
Description of problem:
happening on CLI, UI and API
Getting "zero length field name in format" error message on creating a new custom repository.


Version-Release number of selected component (if applicable):
sat6.2 snap6.1

How reproducible:
always

Steps to Reproduce:
1. create a custom product
2. try create a custom yum repo

Actual results:
"zero length field name in format"
- repo not created

Expected results:
no error message, repo created

Additional info:

Comment 2 Roman Plevka 2016-04-03 19:25:15 UTC
Created attachment 1143093 [details]
foreman/production.log traceback

Comment 3 Roman Plevka 2016-04-04 14:37:47 UTC
Version info:

# rpm -qa | grep satellite
satellite-6.2.0-6.1.beta.el6sat.noarch
tfm-rubygem-foreman_theme_satellite-0.1.3-1.el6sat.noarch


- please note, this is reproducible only on el6 version. el7 seems to work fine

Comment 4 Brad Buckingham 2016-04-04 15:33:54 UTC
Created attachment 1143378 [details]
/var/log/messages error during repo create

Comment 5 Brad Buckingham 2016-04-04 15:35:28 UTC
Discussed this with Michael in IRC.  This issue may be a python 2.6 incompatibility issue that was very recently introduced.

Michael, please do clone to upstream pulp redmine.  Thanks!

Comment 6 Brad Buckingham 2016-04-04 15:36:22 UTC
*** Bug 1323687 has been marked as a duplicate of this bug. ***

Comment 7 pulp-infra@redhat.com 2016-04-04 16:03:39 UTC
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.

Comment 8 pulp-infra@redhat.com 2016-04-04 16:03:42 UTC
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.

Comment 9 pulp-infra@redhat.com 2016-04-04 17:03:39 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 10 pulp-infra@redhat.com 2016-04-04 17:33:39 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 11 pulp-infra@redhat.com 2016-04-04 21:03:35 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 13 Roman Plevka 2016-04-08 20:09:10 UTC
VERIFIED
on sat 6.2.0 snap 7.0


2016-04-07 17:18:06 - robottelo.ssh - DEBUG - >>> [sat6server] LANG=en_US.UTF-8  hammer -v -u admin -p changeme --output=csv repository create --product-id="124" --name="𢞀𦓚燀𥳐밈몗ﻱ" --publish-via-http="true" --url="http://inecas.fedorapeople.org/fakerepos/zoo3/" --content-type="yum"
2016-04-07 17:18:06 - robottelo.ssh - INFO - Instantiated Paramiko client 0x7f5f4e783210
2016-04-07 17:18:09 - robottelo.ssh - INFO - Destroying Paramiko client 0x7f5f4e783210
2016-04-07 17:18:09 - robottelo.ssh - INFO - Destroyed Paramiko client 0x7f5f4e783210
2016-04-07 17:18:09 - robottelo.ssh - DEBUG - <<< stdout
Message,Id,Name
Repository created,74,𢞀𦓚燀𥳐밈몗ﻱ

2016-04-07 17:18:09 - robottelo.ssh - DEBUG - >>> [sat6server] LANG=en_US.UTF-8  hammer -v -u admin -p changeme  repository info --id="74"
2016-04-07 17:18:10 - robottelo.ssh - INFO - Instantiated Paramiko client 0x7f5f4e7983d0
2016-04-07 17:18:12 - robottelo.ssh - INFO - Destroying Paramiko client 0x7f5f4e7983d0
2016-04-07 17:18:12 - robottelo.ssh - INFO - Destroyed Paramiko client 0x7f5f4e7983d0
2016-04-07 17:18:12 - robottelo.ssh - DEBUG - <<< stdout
ID:                 74
Name:               𢞀𦓚燀𥳐밈몗ﻱ
Label:              7f7df3a1-d142-4435-91f2-c2fac9b6f3fc
Organization:       d82kxU
Red Hat Repository: no
Content Type:       yum
URL:                http://inecas.fedorapeople.org/fakerepos/zoo3/
Publish Via HTTP:   yes
Published At:       http://sat6server/pulp/repos/d82kxU/Library/custom/PVkYEkNjOqkKLaKQYlBm/7f7df3a1-d142-4435-91f2-c2fac9b6f3fc
Relative Path:      d82kxU/Library/custom/PVkYEkNjOqkKLaKQYlBm/7f7df3a1-d142-4435-91f2-c2fac9b6f3fc
Download Policy:    immediate
Product:            
    ID:   124
    Name: xcurvHBhQsuaWteCBxlc
GPG Key:            

Sync:               
    Status: Not Synced
Created:            2016/04/07 21:18:08
Updated:            2016/04/07 21:18:09
Content Counts:     
    Packages:       0
    Package Groups: 0
    Errata:         0

Comment 14 pulp-infra@redhat.com 2016-04-26 23:03:59 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 15 pulp-infra@redhat.com 2016-05-09 18:00:46 UTC
The Pulp upstream bug status is at VERIFIED. Updating the external tracker on this bug.

Comment 16 pulp-infra@redhat.com 2016-05-17 20:00:54 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 18 errata-xmlrpc 2016-07-27 09:30:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.