Bug 1323687 - 500 Internal Server Error on Enabling RH repositories
Summary: 500 Internal Server Error on Enabling RH repositories
Keywords:
Status: CLOSED DUPLICATE of bug 1323509
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-04 12:34 UTC by Roman Plevka
Modified: 2018-08-31 15:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-04 15:09:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
/var/log/foreman/production.log (14.10 KB, text/plain)
2016-04-04 12:40 UTC, Roman Plevka
no flags Details

Description Roman Plevka 2016-04-04 12:34:04 UTC
Description of problem:
Trying to enable a rhel repo results in error 500.
(see whole traceback from production.log in attachments) 

Version-Release number of selected component (if applicable):
# rpm -qa | grep satellite
satellite-6.2.0-6.1.beta.el6sat.noarch

How reproducible:
everytime on snap 6.1

Steps to Reproduce:
1. upload a manifest
2. try to enable a rhel repo from Red Hat Repositories

Actual results:
Actions::Katello::RepositorySet::EnableRepository task results in:
500 Internal Server Error

Expected results:
repo enabled, and RH product created

Additional info:

Comment 1 Roman Plevka 2016-04-04 12:40:33 UTC
Created attachment 1143349 [details]
/var/log/foreman/production.log

Comment 3 Roman Plevka 2016-04-04 14:33:17 UTC
Note, this only happens on el6 version. el7 seems to be fine

Comment 4 Mike McCune 2016-04-04 15:09:24 UTC
This is caused by 1321644, dead pulp_workers and celery processes. Closing as a dupe

*** This bug has been marked as a duplicate of bug 1321644 ***

Comment 5 Brad Buckingham 2016-04-04 15:36:22 UTC
Updating the 'duplicate' that this bug is marked against.  The issue here appears to be related to the same as bug 1323509.

*** This bug has been marked as a duplicate of bug 1323509 ***


Note You need to log in before you can comment on or make changes to this bug.