Bug 132371 - duplicated /etc/vimrc on vim packages
Summary: duplicated /etc/vimrc on vim packages
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-11 20:55 UTC by Arenas Belon, Carlo Marcelo
Modified: 2007-11-30 22:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 09:16:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arenas Belon, Carlo Marcelo 2004-09-11 20:55:46 UTC
Description of problem:
update or install vim rpm packages vim-common and vim-minimal and you
get a warning about /etc/vimrc being created as /etc/vimrc.rpmnew (the
way rpm protects configuration changes)

Version-Release number of selected component (if applicable):
6.3.025-2 (probably others)

How reproducible:
always

Steps to Reproduce:
1. yum update vim
2. 
3.
  
Actual results:


Expected results:


Additional info:

as shown below both packages (vim-common and vim-minimal) have this
file and therefore collide on installation :

[root@localhost etc]# rpm -qlv vim-common | grep etc/vimrc
-rw-r--r--    1 root    root             1120 Sep  8 05:08 /etc/vimrc
[root@localhost etc]# rpm -qlv vim-minimal | grep etc/vimrc
-rw-r--r--    1 root    root             1120 Sep  8 05:08 /etc/vimrc

most likely /etc/vimrc should be dropped from the vim-minimal %files
section and add vim-common as a dependency or if vim-minimal is not
meant to have any of the common files anymore add a conflict.

Comment 1 Karsten Hopp 2004-09-11 21:31:17 UTC
the vim-common dependency was dropped intentionally several releases 
ago to allow smaller minimal installs. The only file required to run 
vim-minimal is /etc/vimrc. Without that file cursor, pageup/down and 
other keys won't work. 
Having vim-minimal conflict with vim-common isn't a solution either. 
You need to be able to run /bin/vi without having /usr (think NFS) 
being mounted. 
I need to test some rpm file attributes, maybe one of them fixes 
this. (Btw: This wasn't an issue with previous rpm versions) 

Comment 2 Paul Nasrat 2004-10-19 14:07:51 UTC
Related to this when updating from:

vim-common vim-enchanced vim-minimal 6.3.028-2 to rawhide.

Transaction Check Error:   file /etc/vimrc from install of
                vim-minimal-6.3.030-2 conflicts with file from package
                vim-common-6.3.028-2

vim-enhanced should have a versioned requires on vim-common rather than
unversioned, to allow this migration.




Comment 3 Karsten Hopp 2004-10-20 09:16:00 UTC
fixed in vim-6.3.030-3 

Comment 4 Mark Wilkinson 2004-11-26 20:49:11 UTC
Having just upgraded to Fedora Core 3 I can tell you that this bug
isn't fixed in vim-6.3.030-3. From /root/upgrade.log:
    Upgrading vim-common-6.3.030-3.i386.
    warning: /etc/vimrc created as /etc/vimrc.rpmnew

and:

[mhw@kremvax ~]$ rpm -q -f /etc/vimrc
vim-minimal-6.3.030-3
vim-common-6.3.030-3
[mhw@kremvax ~]$ rpm -qa --filesbypkg 'vim*' | grep /etc/vimrc
vim-minimal               /etc/vimrc
vim-common                /etc/vimrc
[mhw@kremvax ~]$


Comment 5 Karsten Hopp 2004-11-29 14:34:51 UTC
*** Bug 141030 has been marked as a duplicate of this bug. ***

Comment 6 Sitsofe Wheeler 2005-01-13 23:20:53 UTC
Has this really been fixed? I noticed an update done on 12 Jan 2005 to
vim-common-6.3.054-0.fc3.1 and vim-minimal-6.3.054-0.fc3.1 in FC3 seems to have
created a /etc/vimrc.rpmnew ...

Comment 7 W. Michael Petullo 2005-01-20 20:50:00 UTC
Upgrading from 6.3.046-1 to 6.3.058-2 was fine.

Comment 8 W. Michael Petullo 2006-01-20 01:48:12 UTC
See also
https://www.redhat.com/archives/fedora-devel-list/2006-January/msg00945.html and
the related thread on fedora-devel.


Note You need to log in before you can comment on or make changes to this bug.