Bug 132382 - colormap becomes rainbow-ish during install
colormap becomes rainbow-ish during install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 132381 (view as bug list)
Depends On:
Blocks: fedora-ppc
  Show dependency treegraph
 
Reported: 2004-09-11 21:35 EDT by Colin Charles
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-09 14:32:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Charles 2004-09-11 21:35:20 EDT
Description of problem: Anaconda, before formatting the hard disk,
before installing packages, decides its necessary to add rainbow
colors to the screen. 

Version-Release number of selected component (if applicable):
/export/fedorappc/Fedora/RPMS/anaconda-10.0.2-3.ppc.rpm
(rawhide 9/11)

How reproducible:
100% (okay, I lied, I tried this twice)

Steps to Reproduce:
1. Start installation on Mac with Radeon 7500
2. Nice graphical boot (happy!)
3. Suddenly screen becomes rainbow colored when we reach the
partitioning stage
  
Actual results:
Rainbow colored screen

Expected results:
Nice normal colored screen

Additional info:
Which you get back by going to a console and back to the graphical
installer. Its a low priority, if we don't fix it, we'll just clog the
release notes about it as a quick workaround

This is a complaint on YDL's site as well
(http://cvs.terraplex.com/bugzilla/show_bug.cgi?id=20). Guess they
should complain upstream!
Comment 1 Colin Charles 2004-09-11 21:39:36 EDT
*** Bug 132381 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2004-09-13 08:56:33 EDT
I don't have hardware, so there's not really much I can do as this is
completely hardware specific (doesn't happen on !ppc and doesn't
happen on pseries either).  
Comment 3 Bill Nottingham 2004-09-13 13:32:32 EDT
I don't see how this isn't an X bug (or, potentially, a kernel FB bug.)
Comment 4 Wade Mealing 2004-10-03 10:48:35 EDT
Confirmed.

Same problem on my ibook G4.
Comment 5 Paul Nasrat 2004-10-08 05:21:15 EDT
Discussion with benh:

the VT/fbdev code is bogus and sets it's local 8 bits palette
even when it's not the frontmost console

The workaround is to open the new VT before launching X
(by just echoing something to it)

It's whatever VT you open at the moment the problem appearzs
But you can echo ... to all VTs from 0 to 7 just before
launching X, that will work too I suppose.

So workaround on PowerMac would be to initialise all VT's used before X
Comment 6 Brent Fox 2004-10-20 13:17:43 EDT
I see this behavior on my x86 machines.
Comment 7 David Lawrence 2004-10-21 10:48:37 EDT
This also happens on my Titanium Powerbook with latest rawhide. My
video chip is ATI Radeon Mobility M9.
Comment 8 Brent Fox 2004-10-21 11:04:51 EDT
As an additional note, the machines I have seen this on have Matrox
G400  video cards.
Comment 9 Mike A. Harris 2004-10-21 11:07:07 EDT
Does anyone in the Westford or Raleigh office have this problem that
could make their hardware available to someone local to that office
to investigate?

Also, when using rawhide, please indicate the xorg-x11 version-release
that was used to test, as rawhide changes daily.  ;o)
Comment 10 Wade Mealing 2004-10-22 22:26:49 EDT
Confirmed, installed todays rawhide on version xorg-x11-6.8.1-12.

Maybe this is necessary, maybe it isnt.  But the first initial splash
screen is fine. Normal colors. After pressing the "next" button, the
colors go all off. LIke it has been reduced to 16 colors, maybe less.

I'm in the Brisbane office, dont know if that helps any.
Comment 11 Colin Charles 2004-10-23 04:22:45 EDT
Confirmed weirdness with Radeon Mobility 9200 as well, with today's
rawhide xorg-x11-6.8.1-12.ppc and anaconda-10.1.0.0-1.ppc. Funny thing
is, I don't remember this "bug" being around during the FC2 days...
Comment 12 Brent Fox 2004-10-27 13:18:30 EDT
Still seeing the problem with rawhide-nightly as of Oct. 27. 
(xorg-x11-6.8.1-12).

Again, this is on an x86 Dell Precision box with a Matrox G400 video
card.  Mike, I'd be happy to try any kind of testing that you'd like
me to do.
Comment 13 Brent Fox 2004-10-27 14:14:53 EDT
Changing platform to "All"
Comment 14 Brent Fox 2004-10-27 14:18:31 EDT
Some more information.  

I have 3 Dell Precision machines:
1) Matrox G400 - this one shows the problem
2) Matrox G200 - this one shows the probelm too
3) nVidia TNT2 - this one is ok

I also have an Intel pre-production machine with a G400 that also
shows the problem.
Comment 15 Paul Nasrat 2004-10-27 15:22:31 EDT
Brent - does it occur if you pass nofb at the boot prompt?
Comment 16 Brent Fox 2004-10-27 16:15:24 EDT
No, it does not occur if I pass nofb.  Perhaps something has changed
with the kernel's framebuffer handling?
Comment 17 Brent Fox 2004-11-04 10:43:06 EST
I'm going to go out on a limb and chalk this up to something in the
framebuffer in the kernel.  Please correct me if I'm wrong.

Changing component to the kernel.  
Comment 18 Colin Charles 2004-11-05 00:14:33 EST
Since I got the imac installed (#121265), I got the same rainbow-ish
colormap issues. Twice, as per normal. Video card there is a r128.
Comment 19 Paul Nasrat 2004-11-05 10:28:02 EST
Colin if you can bear to do another install I have a small hack to
anaconda which may circumvent this.
Comment 20 Brent Fox 2004-11-05 11:14:37 EST
Paul, does your anaconda hack just pass 'nofb' to the kernel?
Comment 21 Paul Nasrat 2004-11-12 12:59:10 EST
no it loops through tty 2-6 and prints \n
Comment 22 Brent Fox 2004-11-15 14:11:55 EST
mharris: Why did you change the platform to powerpc?  I'm seeing this
on my x86 Dell boxes.
Comment 23 Mike A. Harris 2004-11-16 01:24:40 EST
Brent:  When I skimmed over the bug report, I saw it was filed
against "All" platforms, but noticed ".ppc.rpm" in the first
comment, and skimming further saw ppc mentioned again a few
times.  I didn't notice any other architectures mentioned
anywhere, but didn't read the entire bug report top to bottom
either.  Since I assumed it was PPC specific, I updated the
platform to show PPC to try to better categorize the bug for
investigation.

Thanks for spotting this and updating the report to highlight
x86 also.

Comment 24 Paul Nasrat 2004-11-16 10:34:01 EST
Brent/Colin can you try with a ks install that has the following pre
scriptlet and see if that fixes tested here on imac DV passing
resolution=1024x768

%pre
chvt 6
for in in 2 3 4 5 6; do echo "." > /dev/tty${i} ; done
chvt 7
Comment 25 Brent Fox 2004-11-18 11:17:03 EST
Paul, which tree would you like me to test with?
Comment 26 Paul Nasrat 2004-11-19 11:20:58 EST
FC3 is fine
Comment 28 Peter Jones 2005-01-17 11:54:58 EST
I think this is a dupe of #137849 .  If so, it should be fixed in the
latest build (assuming Jeremy did one on friday afternoon or since then).
Comment 29 Jeremy Katz 2005-01-17 12:47:41 EST
Current rawhide should have the latest changes.  Setting to modified,
reopen if you still see the problem with rawhide.
Comment 30 Paul Nasrat 2005-02-09 14:32:48 EST
Confirmed working on iMac

Note You need to log in before you can comment on or make changes to this bug.