Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 132414 - soundCardBackend.py assumes wrongly that kudzu returns the maker and model separated by "|" on the description
soundCardBackend.py assumes wrongly that kudzu returns the maker and model se...
Status: CLOSED DUPLICATE of bug 132317
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-12 20:53 EDT by Arenas Belon, Carlo Marcelo
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arenas Belon, Carlo Marcelo 2004-09-12 20:53:39 EDT
Description of problem:
system-config-soundcard dies with the following traceback on my system
with a VIA integrated AC97 Audio Controller : 

Traceback (most recent call last):
  File
"/usr/share/system-config-soundcard/system-config-soundcard.py", line
46, in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 87, in
__init__
    self.device, self.module, self.maker, self.model =
self.soundcardBackend.getData(card)
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line
98, in getData
    maker, model = string.split(description, "|")
ValueError: unpack list of wrong size

kudzu shows :

# kudzu -p -cAUDIO -bPCI
-
class: AUDIO
bus: PCI
detached: 0
driver: snd-via82xx
desc: "VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller"
vendorId: 1106
deviceId: 3059
subVendorId: 161f
subDeviceId: 2032
pciType: 1
pcidom:    0
pcibus:  0
pcidev: 11
pcifn:  5

Version-Release number of selected component (if applicable):
1.2.8-1

How reproducible:
always

Steps to Reproduce:
1. system-config-soundcard

Additional info:
changing the matching character to "." instead would work on this case
and for the other 320 Vendors from the pci.ids out of 1691 which have
their names ending on "."

for a comprehensive solution, if Vendor and Model is required as
separate fields, they should be exported as such from the kudzu python
module or the returned fields for card.vendorId and card.deviceId be
used to lookup for that information.

a fast workaround would be to use the description (desc) directly
instead for now as it is mostly only required for the interface and
there is no loose of functionality by not having it segregated on
vendor + model
Comment 1 Bill Nottingham 2004-09-13 13:41:30 EDT

*** This bug has been marked as a duplicate of 132317 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.