Bug 1324509 - Continuous nfs_grace_monitor log messages observed in /var/log/messages
Summary: Continuous nfs_grace_monitor log messages observed in /var/log/messages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: common-ha
Version: mainline
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
: 1322321 (view as bug list)
Depends On: 1321556 1324924
Blocks: 1322321 1324510
TreeView+ depends on / blocked
 
Reported: 2016-04-06 13:52 UTC by Kaleb KEITHLEY
Modified: 2016-06-16 14:03 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1321556
: 1324510 (view as bug list)
Environment:
Last Closed: 2016-06-16 14:03:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-06 15:29:31 UTC
REVIEW: http://review.gluster.org/13919 (common-ha: continuous grace_mon log messages in /var/log/messages) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Kaleb KEITHLEY 2016-04-06 16:11:22 UTC
*** Bug 1322321 has been marked as a duplicate of this bug. ***

Comment 3 Vijay Bellur 2016-04-25 13:29:06 UTC
REVIEW: http://review.gluster.org/13919 (common-ha: continuous grace_mon log messages in /var/log/messages) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 4 Vijay Bellur 2016-04-25 13:39:43 UTC
REVIEW: http://review.gluster.org/13919 (common-ha: continuous grace_mon log messages in /var/log/messages) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 5 Vijay Bellur 2016-04-28 10:19:53 UTC
COMMIT: http://review.gluster.org/13919 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 6530521700d94834d110424f525b95e40bf68094
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Wed Apr 6 11:18:30 2016 -0400

    common-ha: continuous grace_mon log messages in /var/log/messages
    
    messages are seen on RHEL6.x and RHEL7.1 and earlier versions of
    pacemaker. (And RHEL7.2 with RHEL7.1 pacemaker packages.)
    
    It's not possible to query attrd attributes in the older version,
    only set/update/clear them. The messages come from invalid attempts
    to query the attributes.
    
    However it is possible to query crm attributes. The fix here is to
    create a "shadow" crm attribute for the attrd attribute. Changes are
    made to both, queries are made on the crm attribute.
    
    (Resource Agents "follow" the attrd attribute using constraint locations,
    so we must keep the attrd attribute.)
    
    Change-Id: I84ac1a80673e528d98b67b7d5062e21dcf744d4a
    BUG: 1324509
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13919
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: soumya k <skoduri@redhat.com>

Comment 6 Niels de Vos 2016-06-16 14:03:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.