Bug 1324510 - Continuous nfs_grace_monitor log messages observed in /var/log/messages
Summary: Continuous nfs_grace_monitor log messages observed in /var/log/messages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: common-ha
Version: 3.7.10
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On: 1321556 1324509 1324924
Blocks: 1322321
TreeView+ depends on / blocked
 
Reported: 2016-04-06 13:53 UTC by Kaleb KEITHLEY
Modified: 2016-06-28 12:13 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of: 1324509
Environment:
Last Closed: 2016-06-28 11:37:49 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-06 16:14:51 UTC
REVIEW: http://review.gluster.org/13920 (common-ha: continuous grace_mon log messages in /var/log/messages) posted (#2) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Vijay Bellur 2016-04-25 13:40:48 UTC
REVIEW: http://review.gluster.org/13920 (common-ha: continuous grace_mon log messages in /var/log/messages) posted (#3) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Vijay Bellur 2016-04-28 10:20:05 UTC
COMMIT: http://review.gluster.org/13920 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit f46206030afdd5337d857761e36936c13feee72d
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Wed Apr 6 12:00:52 2016 -0400

    common-ha: continuous grace_mon log messages in /var/log/messages
    
    messages are seen on RHEL6.x and RHEL7.1 and earlier versions of
    pacemaker. (And RHEL7.2 with RHEL7.1 pacemaker packages.)
    
    It's not possible to query attrd attributes in the older version,
    only set/update/clear them. The messages come from invalid attempts
    to query the attributes.
    
    However it is possible to query crm attributes. The fix here is to
    create a "shadow" crm attribute for the attrd attribute. Changes are
    made to both, queries are made on the crm attribute.
    
    (Resource Agents "follow" the attrd attribute using constraint locations,
    so we must keep the attrd attribute.)
    
    Backport of
    > Change-Id: I84ac1a80673e528d98b67b7d5062e21dcf744d4a
    > BUG: 1324509
    > http://review.gluster.org/#/c/13919/
    
    Change-Id: I7301c48849496be026ef598c588e78c68f273a8a
    BUG: 1324510
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13920
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: soumya k <skoduri@redhat.com>

Comment 4 Kaushal 2016-06-28 12:13:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.