Bug 1324921 - [RFE] hosted-engine should have a flag to check whether the engine is deployed
Summary: [RFE] hosted-engine should have a flag to check whether the engine is deployed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: RFEs
Version: 2.0.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.0.0-beta
: 2.0.0
Assignee: Ryan Barry
QA Contact: Nikolai Sednev
URL:
Whiteboard:
: 1203117 (view as bug list)
Depends On:
Blocks: ovirt-node-ng 1318415 1416029
TreeView+ depends on / blocked
 
Reported: 2016-04-07 15:11 UTC by Ryan Barry
Modified: 2017-05-11 09:28 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this update, a flag has been added to confirm that the self-hosted engine has been deployed. Using the --check-deployed flag checks whether the self-hosted engine has been deployed and returns nothing if the self-hosted engine is deployed or an error message if the self-hosted engine has not been deployed.
Clone Of:
Environment:
Last Closed: 2016-07-05 07:57:41 UTC
oVirt Team: Integration
rule-engine: ovirt-4.0.0+
rule-engine: exception+
mavital: testing_plan_complete+
ylavi: planning_ack+
sbonazzo: devel_ack+
nsednev: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 56722 master MERGED Add --check-deployed to hosted-engine 2016-04-28 14:50:13 UTC

Description Ryan Barry 2016-04-07 15:11:03 UTC
Description of problem:
Currently the hosted-engine command can already detect this if "--vm-status" is run on a system where the engine has not been deployed.

However, there's currently no way to simply check whether it's been deployed or not. hosted-engine checks a configuration file, and spits out a warning if it has not been, but there is no way for users to tell whether it's been deployed other than trying a command and getting this error.

This could be --check-deployed, or some other flag.

Comment 1 Red Hat Bugzilla Rules Engine 2016-04-07 15:11:09 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 2 Fabian Deutsch 2016-04-26 13:30:46 UTC
Is there any ETA for this fix?
The Cockpit implementation is depending on this feature

Comment 3 Sandro Bonazzola 2016-05-02 10:03:35 UTC
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.

Comment 4 Nikolai Sednev 2016-05-23 14:21:17 UTC
The flag exists as appears bellow:
man hosted-engine --check-deployed 
--check-deployed
              Checks whether the hosted engine has been deployed.
In case of HE is deployed, the command returns nothing to customer, otherwise returns:

hosted-engine --check-deployed
The hosted engine has not been deployed

Checked on:
ovirt-node-ng-installer-ovirt-4.0-2016052300.iso
ovirt-vmconsole-host-1.0.2-0.0.master.20160517094103.git06df50a.el7.noarch
ovirt-setup-lib-1.0.2-0.0.master.20160502125738.gitf05af9e.el7.centos.noarch
ovirt-release40-4.0.0-0.3.beta1.noarch
ovirt-vmconsole-1.0.2-0.0.master.20160517094103.git06df50a.el7.noarch
ovirt-engine-sdk-python-3.6.5.1-0.1.20160507.git5fb7e0e.el7.centos.noarch
ovirt-host-deploy-1.5.0-0.1.alpha1.el7.centos.noarch
ovirt-hosted-engine-setup-2.0.0-0.1.beta1.el7.centos.noarch
ovirt-release-host-node-4.0.0-0.3.beta1.el7.noarch
ovirt-hosted-engine-ha-2.0.0-0.1.beta1.el7.centos.noarch
ovirt-node-ng-image-update-placeholder-4.0.0-0.3.beta1.el7.noarch
qemu-kvm-tools-ev-2.3.0-31.el7_2.10.1.x86_64
mom-0.5.3-1.1.el7.noarch
qemu-kvm-ev-2.3.0-31.el7_2.10.1.x86_64
vdsm-4.17.999-1155.gitcf216a0.el7.centos.x86_64
libvirt-client-1.2.17-13.el7_2.4.x86_64
qemu-kvm-common-ev-2.3.0-31.el7_2.10.1.x86_64
sanlock-3.2.4-2.el7_2.x86_64
Linux version 3.10.0-327.18.2.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ) #1 SMP Thu May 12 11:03:55 UTC 2016
Linux 3.10.0-327.18.2.el7.x86_64 #1 SMP Thu May 12 11:03:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
CentOS Linux release 7.2.1511 (Core)

Comment 5 Ryan Barry 2016-05-25 14:28:05 UTC
*** Bug 1203117 has been marked as a duplicate of this bug. ***

Comment 6 Sandro Bonazzola 2016-07-05 07:57:41 UTC
oVirt 4.0.0 has been released, closing current release.


Note You need to log in before you can comment on or make changes to this bug.