Bug 1318415 - [RFE] [Cockpit] Add Hosted Engine status to dashboard
Summary: [RFE] [Cockpit] Add Hosted Engine status to dashboard
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: RFEs
Version: ---
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.0.1
: 4.0
Assignee: Ryan Barry
QA Contact: cshao
URL:
Whiteboard:
: 1332445 (view as bug list)
Depends On: 1324921 1324923
Blocks: ovirt-node-ng 1304617
TreeView+ depends on / blocked
 
Reported: 2016-03-16 19:52 UTC by Ryan Barry
Modified: 2016-07-19 06:24 UTC (History)
8 users (show)

Fixed In Version: cockpit-ovirt-dashboard-0.10.5-1.0.0.el7ev
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 06:24:20 UTC
oVirt Team: Node
Embargoed:
dfediuck: ovirt-4.0.z+
rule-engine: exception+
mgoldboi: planning_ack+
fdeutsch: devel_ack+
ycui: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 58754 0 None MERGED dashboard: Add hosted-engine status 2020-11-15 11:48:31 UTC
oVirt gerrit 59350 0 None MERGED Add a backend to set hosted engine maintenance modes 2020-11-15 11:48:31 UTC

Description Ryan Barry 2016-03-16 19:52:17 UTC
Description of problem:

The next-gen node Cockpit dashboard should include the status of hosted engine.

Comment 1 Red Hat Bugzilla Rules Engine 2016-03-17 01:28:05 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 2 Ryan Barry 2016-05-06 13:51:46 UTC
*** Bug 1332445 has been marked as a duplicate of this bug. ***

Comment 3 Ryan Barry 2016-05-19 12:23:31 UTC
bz#1324921 is merged, but we're still waiting for bz#1324923 to implement this logic, since adding status depends on parsable output, and we don't want to implement a parser for the human-readable output "hosted-engine --vm-status" provides right now, nor can we use the python client directly.

The basic game plan is:

Open Hosted Engine Page
Verify "--check-deployed" (bz#1324921)
If it hasn't been deployed, show the setup splash
If it has been deployed, show a different page, which has hosted engine status, buttons for changing maintenance mode, etc. We need bz#1324923 on MODIFIED to implement this.

Comment 4 wanghui 2016-06-23 06:21:39 UTC
Test version:
rhev-hypervisor7-ng-4.0-20160622.1
cockpit-ovirt-dashboard-0.10.5-0.0.1.el7ev.noarch

According to comment#3, after Hosted Engine been deployed, it has a different page which has hosted engine status. 

But we still has no button for changing maintenance mode now.

Comment 5 Red Hat Bugzilla Rules Engine 2016-06-23 06:21:44 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 6 Ryan Barry 2016-06-23 11:57:22 UTC
This will be resolved with the build for beta 2. A patch for maintenance buttons is already merged upstream.

Comment 7 Yaniv Lavi 2016-06-28 13:43:27 UTC
Should this be MODIFIED?

Comment 8 Ryan Barry 2016-06-28 14:03:56 UTC
Not yet -- the maintenance buttons are not part of any downstream builds yet (we delayed everything until beta 1 was out the door).

It will be included in a build and moved to MODIFIED near the end of this week, with delivery of a build.

Comment 9 Ryan Barry 2016-06-28 14:04:52 UTC
Ah, scratch that -- I see this is filed against an upstream component. Then yes.

Comment 10 cshao 2016-07-13 08:58:50 UTC
Test version:
redhat-virtualization-host-4.0-20160708.0 
imgbased-0.7.2-0.1.el7ev.noarch
redhat-release-virtualization-host-4.0-0.13.el7.x86_64
cockpit-0.108-1.el7.x86_64

After deploy hosted engine been deployed, dashboard can show HE status and maintenance buttons now, so the bug is fixed.
Change bug status to VERIFIED.

Comment 11 Sandro Bonazzola 2016-07-19 06:24:20 UTC
Since the problem described in this bug report should be
resolved in oVirt 4.0.1 released on July 19th 2016, it has been closed with a
resolution of CURRENT RELEASE.

For information on the release, and how to update to this release, follow the link below.

If the solution does not work for you, open a new bug report.

http://www.ovirt.org/release/4.0.1/


Note You need to log in before you can comment on or make changes to this bug.