Bug 132498 - Inserting and removing SanDisk USB Cruzer Mini flash device causes instability
Inserting and removing SanDisk USB Cruzer Mini flash device causes instability
Status: CLOSED DUPLICATE of bug 134001
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: fedora-ppc
  Show dependency treegraph
 
Reported: 2004-09-14 00:56 EDT by Ethan Blanton
Modified: 2015-01-04 17:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-20 00:16:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages output for this event (7.50 KB, text/plain)
2004-09-14 01:04 EDT, Ethan Blanton
no flags Details

  None (edit)
Description Ethan Blanton 2004-09-14 00:56:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
Note: I'm not sure this is a kernel problem.

Inserting and removing a USB Flash disk (Cruzer Mini 128MB from
SanDisk) caused the keyboard and network to become (largely)
nonresponsive.  The magic keys (brightness up/down, mac_hid mouse
alternatives) worked, but keyboard input did not; the mouse was
responsive, as were X11 applications.

Note that mounting the devices was NOT necessary, merely inserting and
removing it.

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.541

How reproducible:
Didn't try (I plan to, but recovering took some time due to disk
badness/fsck, so tonight is out.)

Steps to Reproduce:
1. Insert Cruzer Mini
2. Wait for /var/log/messages to settle
3. Remove Cruzer Mini
4. Fly into a rage when things break
Comment 1 Ethan Blanton 2004-09-14 01:04:35 EDT
Created attachment 103818 [details]
/var/log/messages output for this event
Comment 2 Kurt Erickson 2004-10-11 16:46:35 EDT
Interestingly, I've experienced the same problem with a different usb
device, a usbvision driver compatible usb video adapter. It isn't very
reproduceable, though. I've only had it happen once or twice.
Comment 3 Colin Charles 2004-10-13 08:20:35 EDT
I got my hands on one of these items today, plugged it in, and
gnome-volume-manager mounted it for me. Unmounted just fine as well.
No apparent problems on my iBook (and I'm running an old-ish rawhide tree)

http://fedoraproject.org/fedorappc/ is where the fc3test2 tree is from
(well, pre-test2, before the dev removal mess). So please check to see
if this is resolved
Comment 4 Dave Jones 2004-11-20 00:16:12 EST

*** This bug has been marked as a duplicate of 134001 ***

Note You need to log in before you can comment on or make changes to this bug.