Bug 13250 - bugzilla is 7-bit.
Summary: bugzilla is 7-bit.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General   
(Show other bugs)
Version: 2.8
Hardware: All
OS: Linux
medium
high vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 15303 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-30 05:56 UTC by Pekka Savola
Modified: 2007-04-18 16:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-05 07:14:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-06-30 05:56:57 UTC
Bugzilla seems to change the 8-bit special characters to 7-bit.  E.g. 'a'
with two dots --> d. 

See bug #12250 for an example.

Comment 1 Dams 2002-10-08 07:19:55 UTC
Why not make bugzilla UTF-8 compliant ?

Comment 2 Mike A. Harris 2002-10-08 07:53:40 UTC
Bugzilla is not 8bit clean.  The problem is really, how does bugzilla know
what encoding you're using to submit a report with?  And how does it know
what encoding it should use to display the report to another user?

Both are probably solveable, but I don't think it would be an easy task
per se.  (or someone would have likely done it by now.)  ;o)

If bugzilla did use UTF-8, then how would someone using ISO8859-x to
file a bug report end up with their bug being treated?  Garbled as
UTF-8?  Not sure, but this sort of thing is more of a major bugzilla
feature request that is probably best to as a request to bugzilla.org



Comment 3 Aleksey Nogin 2002-12-13 14:59:48 UTC
*** Bug 15303 has been marked as a duplicate of this bug. ***

Comment 4 Aleksey Nogin 2003-01-05 07:11:54 UTC
Discussion in bug 80349 seems to indicate that this is fixed now.


Note You need to log in before you can comment on or make changes to this bug.