Bug 1325020 - [abrt] WARNING: CPU: 3 PID: 1648 at drivers/gpu/drm/i915/intel_uncore.c:599 hsw_unclaimed_reg_debug+0x6a/0x90 [i915]()
Summary: [abrt] WARNING: CPU: 3 PID: 1648 at drivers/gpu/drm/i915/intel_uncore.c:599 h...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:99886d26e86696ee569667ddeaa...
: 1333613 1339775 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-07 21:14 UTC by madstitz
Modified: 2016-10-01 20:41 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-08 20:26:36 UTC
Type: ---


Attachments (Terms of Use)
File: dmesg (78.38 KB, text/plain)
2016-04-07 21:14 UTC, madstitz
no flags Details

Description madstitz 2016-04-07 21:14:24 UTC
Additional info:
reporter:       libreport-2.6.4
WARNING: CPU: 3 PID: 1648 at drivers/gpu/drm/i915/intel_uncore.c:599 hsw_unclaimed_reg_debug+0x6a/0x90 [i915]()
Unclaimed register detected after reading register 0x65f10
Modules linked in: fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_broute bridge stp llc ebtable_filter ebtable_nat ebtables ip6table_mangle ip6table_raw ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_security ip6table_filter ip6_tables iptable_mangle iptable_raw iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_security binfmt_misc bnep cpufreq_stats vfat fat hid_multitouch snd_hda_codec_hdmi dell_led snd_hda_codec_realtek snd_hda_codec_generic snd_hda_intel i2c_designware_platform snd_hda_codec i2c_designware_core intel_rapl brcmfmac x86_pkg_temp_thermal snd_hda_core coretemp dell_wmi snd_hwdep
 kvm_intel brcmutil dell_laptop dcdbas cfg80211 kvm snd_seq rtsx_pci_ms memstick snd_seq_device irqbypass snd_pcm uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 snd_timer videobuf2_core joydev snd videodev i2c_i801 soundcore btusb media idma64 btrtl mei_me mei hci_uart btbcm shpchp btqca processor_thermal_device btintel intel_soc_dts_iosf intel_lpss_pci bluetooth int3403_thermal dell_smo8800 rfkill pinctrl_sunrisepoint intel_lpss_acpi pinctrl_intel intel_lpss int3402_thermal acpi_als int340x_thermal_zone kfifo_buf intel_hid int3400_thermal sparse_keymap industrialio acpi_thermal_rel tpm_tis tpm acpi_pad nfsd auth_rpcgss nfs_acl lockd grace dm_crypt i915 nouveau rtsx_pci_sdmmc mmc_core crct10dif_pclmul crc32_pclmul crc32c_intel mxm_wmi i2c_algo_bit drm_kms_helper ghash_clmulni_intel
 ttm drm serio_raw rtsx_pci nvme i2c_hid video wmi fjes sunrpc scsi_transport_iscsi
CPU: 3 PID: 1648 Comm: pulseaudio Not tainted 4.5.0-302.fc24.x86_64 #1
Hardware name: Dell Inc. XPS 15 9550/0N7TVV, BIOS 01.01.19 01/25/2016
 0000000000000086 000000001cc2a6f0 ffff8804a6e637b8 ffffffff813d3fdf
 ffff8804a6e63800 ffffffffa046a6a8 ffff8804a6e637f0 ffffffff810a5de2
 ffff8804a4660000 ffff8804a4660080 0000000000000000 0000000000000206
Call Trace:
 [<ffffffff813d3fdf>] dump_stack+0x63/0x84
 [<ffffffff810a5de2>] warn_slowpath_common+0x82/0xc0
 [<ffffffff810a5e7c>] warn_slowpath_fmt+0x5c/0x80
 [<ffffffff817cc1e9>] ? schedule_hrtimeout_range_clock+0xb9/0x1a0
 [<ffffffffa03e111a>] hsw_unclaimed_reg_debug+0x6a/0x90 [i915]
 [<ffffffffa03e82d9>] gen9_read32+0x119/0x320 [i915]
 [<ffffffffa03ed007>] i915_audio_component_codec_wake_override+0x87/0xc0 [i915]
 [<ffffffffa0931b2f>] snd_hdac_set_codec_wakeup+0x3f/0xa0 [snd_hda_core]
 [<ffffffffa06a751a>] azx_runtime_resume+0x18a/0x1b0 [snd_hda_intel]
 [<ffffffff8142069d>] pci_pm_runtime_resume+0x7d/0xb0
 [<ffffffff81420620>] ? pci_restore_standard_config+0x40/0x40
 [<ffffffff8151b927>] __rpm_callback+0x27/0x70
 [<ffffffff81420620>] ? pci_restore_standard_config+0x40/0x40
 [<ffffffff8151b994>] rpm_callback+0x24/0x80
 [<ffffffff81420620>] ? pci_restore_standard_config+0x40/0x40
 [<ffffffff8151c321>] rpm_resume+0x491/0x6a0
 [<ffffffff813a527d>] ? blk_account_io_start+0xdd/0x1d0
 [<ffffffff8151c163>] rpm_resume+0x2d3/0x6a0
 [<ffffffff8121bd55>] ? __kmalloc+0x1e5/0x220
 [<ffffffff8151d35e>] __pm_runtime_resume+0x4e/0x70
 [<ffffffffa092cea3>] snd_hdac_power_up+0x13/0x20 [snd_hda_core]
 [<ffffffffa06baa4c>] azx_pcm_open+0x1dc/0x3c0 [snd_hda_codec]
 [<ffffffffa07a24de>] snd_pcm_open_substream+0x7e/0x130 [snd_pcm]
 [<ffffffffa07a2647>] snd_pcm_open+0xb7/0x250 [snd_pcm]
 [<ffffffff8121b012>] ? kmem_cache_alloc_trace+0x182/0x1d0
 [<ffffffffa07598ca>] ? snd_card_file_add+0x2a/0xd0 [snd]
 [<ffffffff810d0150>] ? wake_up_q+0x70/0x70
 [<ffffffffa07a2827>] snd_pcm_capture_open+0x47/0x70 [snd_pcm]
 [<ffffffffa0759461>] snd_open+0xb1/0x180 [snd]
 [<ffffffff812473c0>] chrdev_open+0xb0/0x180
 [<ffffffff8123fe41>] do_dentry_open+0x201/0x2e0
 [<ffffffff81247310>] ? cdev_put+0x30/0x30
 [<ffffffff81241219>] vfs_open+0x59/0x60
 [<ffffffff812508f3>] path_openat+0x1d3/0x14d0
 [<ffffffff811f6cf1>] ? page_add_file_rmap+0x51/0x60
 [<ffffffff81253751>] do_filp_open+0x91/0x100
 [<ffffffff81260a8f>] ? __alloc_fd+0x3f/0x170
 [<ffffffff812415b0>] do_sys_open+0x130/0x220
 [<ffffffff812416be>] SyS_open+0x1e/0x20
 [<ffffffff817cd0ee>] entry_SYSCALL_64_fastpath+0x12/0x6d

Comment 1 madstitz 2016-04-07 21:14:32 UTC
Created attachment 1144899 [details]
File: dmesg

Comment 2 eaon 2016-05-06 00:51:17 UTC
*** Bug 1333613 has been marked as a duplicate of this bug. ***

Comment 3 eaon 2016-05-12 16:59:55 UTC
Description of problem:
After setting up and calibrating powertop, this occured reproducibly during

$ powertop --auto-tune

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.7.0
cmdline:        BOOT_IMAGE=/boot/vmlinuz-4.5.3-300.fc24.x86_64 root=/dev/mapper/lvm-root ro rd.luks.uuid=luks-d3d83d48-8b4a-4ee7-8b9b-88b742e4f808 rd.lvm.lv=lvm/root rd.lvm.lv=lvm/swap resume=UUID=1d429030-4e29-4bbd-80a2-bfb3219a203c quiet
kernel:         4.5.3-300.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 3 PID: 3355 at drivers/gpu/drm/i915/intel_uncore.c:599 hsw_unclaimed_reg_debug+0x6a/0x90 [i915]()
Unclaimed register detected after reading register 0x65f10
Modules linked in: cpufreq_stats rfcomm fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_broute bridge ebtable_nat ip6table_mangle ip6table_security ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw iptable_mangle iptable_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_raw ebtable_filter ebtables ip6table_filter ip6_tables bnep vfat fat uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core videodev btusb media btrtl arc4 iwlmvm snd_soc_skl snd_soc_skl_ipc snd_soc_sst_ipc snd_soc_sst_dsp mac80211 snd_hda_ext_core snd_soc_sst_match snd_hda_codec_hdmi snd_soc_core i2c_designware_platform
 snd_hda_codec_realtek intel_rapl i2c_designware_core snd_hda_codec_generic iwlwifi x86_pkg_temp_thermal snd_compress coretemp snd_pcm_dmaengine ac97_bus kvm_intel snd_hda_intel snd_hda_codec kvm cfg80211 snd_hda_core snd_hwdep snd_seq irqbypass snd_seq_device snd_pcm mei_me mei hci_uart i2c_i801 joydev snd_timer shpchp btbcm idma64 btqca intel_lpss_pci btintel thinkpad_acpi bluetooth tpm_infineon snd soundcore rfkill pinctrl_sunrisepoint pinctrl_intel intel_lpss_acpi intel_lpss soc_button_array acpi_pad tpm_tis tpm nfsd auth_rpcgss nfs_acl lockd grace dm_crypt 8021q garp stp llc mrp i915 e1000e crct10dif_pclmul i2c_algo_bit crc32_pclmul drm_kms_helper crc32c_intel ghash_clmulni_intel drm ptp serio_raw pps_core wmi i2c_hid video fjes sunrpc scsi_transport_iscsi
CPU: 3 PID: 3355 Comm: tlp Not tainted 4.5.3-300.fc24.x86_64 #1
Hardware name: LENOVO 20GJCTO1WW/20GJCTO1WW, BIOS R0CET23W (1.11 ) 04/01/2016
 0000000000000086 000000005d26f953 ffff8803aed9ba60 ffffffff813d4b6f
 ffff8803aed9baa8 ffffffffa02866a8 ffff8803aed9ba98 ffffffff810a5f72
 ffff880409490000 ffff880409490080 0000000000000000 0000000000000202
Call Trace:
 [<ffffffff813d4b6f>] dump_stack+0x63/0x84
 [<ffffffff810a5f72>] warn_slowpath_common+0x82/0xc0
 [<ffffffff810a600c>] warn_slowpath_fmt+0x5c/0x80
 [<ffffffff817cf809>] ? schedule_hrtimeout_range_clock+0xb9/0x1a0
 [<ffffffffa01fd20a>] hsw_unclaimed_reg_debug+0x6a/0x90 [i915]
 [<ffffffffa02043d9>] gen9_read32+0x119/0x320 [i915]
 [<ffffffffa0209127>] i915_audio_component_codec_wake_override+0x87/0xc0 [i915]
 [<ffffffffa0518d1f>] snd_hdac_set_codec_wakeup+0x3f/0xa0 [snd_hda_core]
 [<ffffffffa04c1a95>] azx_runtime_resume+0x185/0x1a0 [snd_hda_intel]
 [<ffffffff814212dd>] pci_pm_runtime_resume+0x7d/0xb0
 [<ffffffff81421260>] ? pci_restore_standard_config+0x40/0x40
 [<ffffffff8151f8a7>] __rpm_callback+0x27/0x70
 [<ffffffff81421260>] ? pci_restore_standard_config+0x40/0x40
 [<ffffffff8151f914>] rpm_callback+0x24/0x80
 [<ffffffff81421260>] ? pci_restore_standard_config+0x40/0x40
 [<ffffffff815202a1>] rpm_resume+0x491/0x6a0
 [<ffffffff815200e3>] rpm_resume+0x2d3/0x6a0
 [<ffffffff81520bf5>] ? rpm_idle+0x25/0x250
 [<ffffffff815215eb>] pm_runtime_forbid+0x4b/0x50
 [<ffffffffa06906a4>] snd_hda_set_power_save+0x54/0xc0 [snd_hda_codec]
 [<ffffffffa04c2485>] param_set_xint+0x85/0xa0 [snd_hda_intel]
 [<ffffffff810c3a94>] param_attr_store+0x64/0xd0
 [<ffffffff810c311e>] module_attr_store+0x1e/0x30
 [<ffffffff812c6e89>] sysfs_kf_write+0x39/0x40
 [<ffffffff812c644c>] kernfs_fop_write+0x11c/0x170
 [<ffffffff81242827>] __vfs_write+0x37/0x120
 [<ffffffff81261393>] ? __fd_install+0x33/0xe0
 [<ffffffff810ef0d2>] ? percpu_down_read+0x12/0x50
 [<ffffffff81243132>] vfs_write+0xa2/0x190
 [<ffffffff81244065>] SyS_write+0x55/0xc0
 [<ffffffff817d06ee>] entry_SYSCALL_64_fastpath+0x12/0x6d

Comment 4 Jason Birch 2016-05-25 20:26:30 UTC
*** Bug 1339775 has been marked as a duplicate of this bug. ***

Comment 5 Hans de Goede 2016-07-12 16:39:22 UTC

*** This bug has been marked as a duplicate of bug 1340218 ***

Comment 6 Fedora Update System 2016-07-29 12:20:37 UTC
kernel-4.6.5-200.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-754e4768d8

Comment 7 Fedora Update System 2016-07-29 12:21:23 UTC
kernel-4.6.5-300.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-30e3636e79

Comment 8 Fedora Update System 2016-07-30 19:27:02 UTC
kernel-4.6.5-200.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-754e4768d8

Comment 9 Fedora Update System 2016-07-30 19:27:27 UTC
kernel-4.6.5-300.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-30e3636e79

Comment 10 Fedora Update System 2016-08-08 20:25:23 UTC
kernel-4.6.5-300.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-08-08 23:52:36 UTC
kernel-4.6.5-200.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.