Bug 1340218 - [abrt] WARNING: CPU: 2 PID: 1944 at drivers/gpu/drm/i915/intel_uncore.c:649 __unclaimed_reg_debug+0x7b/0x90 [i915]
Summary: [abrt] WARNING: CPU: 2 PID: 1944 at drivers/gpu/drm/i915/intel_uncore.c:649 _...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 23
Hardware: x86_64
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0f3264c6705a7ce97d0fa04ea86...
: 1352718 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-26 18:09 UTC by Franck WIATROWSKI
Modified: 2016-08-08 23:52 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-08 20:26:42 UTC
Type: ---


Attachments (Terms of Use)
File: dmesg (71.89 KB, text/plain)
2016-05-26 18:09 UTC, Franck WIATROWSKI
no flags Details
Lenovo ThinkPad x260 dmesg (66.28 KB, text/plain)
2016-07-08 22:47 UTC, Joonas Kylmälä
no flags Details

Description Franck WIATROWSKI 2016-05-26 18:09:30 UTC
Additional info:
reporter:       libreport-2.6.4
WARNING: CPU: 2 PID: 1944 at drivers/gpu/drm/i915/intel_uncore.c:649 __unclaimed_reg_debug+0x7b/0x90 [i915]
Unclaimed register detected after reading register 0x65f10
Modules linked in: cpufreq_stats rfcomm ccm cmac hid_logitech_hidpp snd_usb_audio snd_usbmidi_lib snd_rawmidi hid_logitech_dj fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw ip6table_security ip6table_mangle ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_raw iptable_security iptable_mangle bnep arc4 intel_rapl x86_pkg_temp_thermal coretemp kvm_intel vfat fat kvm snd_hda_codec_hdmi dell_led irqbypass snd_soc_skl crct10dif_pclmul crc32_pclmul snd_soc_skl_ipc crc32c_intel
 snd_soc_sst_ipc snd_soc_sst_dsp ghash_clmulni_intel snd_hda_ext_core snd_soc_sst_match snd_soc_core snd_hda_codec_realtek snd_compress snd_hda_codec_generic snd_pcm_dmaengine ac97_bus iwlmvm dw_dmac_core snd_hda_intel mac80211 snd_hda_codec i2c_designware_platform i2c_designware_core dell_wmi snd_hda_core snd_hwdep dell_laptop snd_seq dell_smbios dcdbas snd_seq_device snd_pcm uvcvideo iwlwifi videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core cfg80211 snd_timer videodev snd rtsx_pci_ms memstick soundcore joydev media i2c_i801 mei_me idma64 mei intel_pch_thermal hci_uart btusb intel_lpss_pci btrtl shpchp btbcm btqca btintel processor_thermal_device bluetooth intel_soc_dts_iosf wmi pinctrl_sunrisepoint intel_hid intel_lpss_acpi int3403_thermal int3400_thermal pinctrl_intel
 rfkill intel_lpss sparse_keymap int340x_thermal_zone acpi_thermal_rel acpi_als kfifo_buf industrialio acpi_pad tpm_tis tpm nfsd auth_rpcgss nfs_acl lockd grace sunrpc hid_multitouch i915 rtsx_pci_sdmmc mmc_core i2c_algo_bit drm_kms_helper drm serio_raw nvme rtsx_pci nvme_core i2c_hid video fjes
CPU: 2 PID: 1944 Comm: alsa-sink-ALC32 Not tainted 4.6.0-1.fc25.x86_64 #1
Hardware name: Dell Inc. XPS 13 9350/09JHRY, BIOS 1.3.3 03/01/2016
 0000000000000086 00000000563a0df5 ffff8804695cb750 ffffffff813dc66f
 ffff8804695cb7a0 0000000000000000 ffff8804695cb790 ffffffff810a740b
 00000289695cb798 0000000000000000 0000000000000001 0000000000065f10
Call Trace:
 [<ffffffff813dc66f>] dump_stack+0x63/0x84
 [<ffffffff810a740b>] __warn+0xcb/0xf0
 [<ffffffff810a748f>] warn_slowpath_fmt+0x5f/0x80
 [<ffffffff81115820>] ? __hrtimer_init+0xa0/0xa0
 [<ffffffffc016e50b>] __unclaimed_reg_debug+0x7b/0x90 [i915]
 [<ffffffffc0173f5b>] gen9_read32+0x35b/0x390 [i915]
 [<ffffffffc017a579>] i915_audio_component_codec_wake_override+0x39/0xb0 [i915]
 [<ffffffffc0658c4f>] snd_hdac_set_codec_wakeup+0x3f/0xa0 [snd_hda_core]
 [<ffffffffc079b8ad>] hda_intel_init_chip+0x12d/0x190 [snd_hda_intel]
 [<ffffffffc079b9b3>] azx_runtime_resume+0xa3/0x190 [snd_hda_intel]
 [<ffffffff8142abbb>] pci_pm_runtime_resume+0x7b/0xa0
 [<ffffffff8142ab40>] ? pci_restore_standard_config+0x40/0x40
 [<ffffffff81525c77>] __rpm_callback+0x27/0x70
 [<ffffffff8142ab40>] ? pci_restore_standard_config+0x40/0x40
 [<ffffffff81525ce4>] rpm_callback+0x24/0x80
 [<ffffffff8142ab40>] ? pci_restore_standard_config+0x40/0x40
 [<ffffffff81526671>] rpm_resume+0x491/0x6a0
 [<ffffffff817d9e35>] ? schedule+0x35/0x80
 [<ffffffff815264b3>] rpm_resume+0x2d3/0x6a0
 [<ffffffff81223cd5>] ? __kmalloc+0x1e5/0x220
 [<ffffffff815276ae>] __pm_runtime_resume+0x4e/0x70
 [<ffffffffc0652e93>] snd_hdac_power_up+0x13/0x20 [snd_hda_core]
 [<ffffffffc069e9dc>] azx_pcm_open+0x1dc/0x3c0 [snd_hda_codec]
 [<ffffffffc062247b>] snd_pcm_open_substream+0x7b/0x130 [snd_pcm]
 [<ffffffffc06225e7>] snd_pcm_open+0xb7/0x250 [snd_pcm]
 [<ffffffff81223162>] ? kmem_cache_alloc_trace+0x182/0x1d0
 [<ffffffffc04c88ca>] ? snd_card_file_add+0x2a/0xd0 [snd]
 [<ffffffff810d2050>] ? wake_up_q+0x70/0x70
 [<ffffffffc0622834>] snd_pcm_playback_open+0x44/0x70 [snd_pcm]
 [<ffffffffc04c8461>] snd_open+0xb1/0x180 [snd]
 [<ffffffff8124e780>] chrdev_open+0xb0/0x180
 [<ffffffff81247041>] do_dentry_open+0x201/0x2e0
 [<ffffffff8124e6d0>] ? cdev_put+0x30/0x30
 [<ffffffff81248434>] vfs_open+0x54/0x80
 [<ffffffff8125593c>] ? may_open+0x8c/0x100
 [<ffffffff812586d1>] path_openat+0x1d1/0x15b0
 [<ffffffff8125ace1>] do_filp_open+0x91/0x100
 [<ffffffff8126805f>] ? __alloc_fd+0x3f/0x170
 [<ffffffff812487f0>] do_sys_open+0x130/0x220
 [<ffffffff812488fe>] SyS_open+0x1e/0x20
 [<ffffffff817ddef2>] entry_SYSCALL_64_fastpath+0x1a/0xa4

Comment 1 Franck WIATROWSKI 2016-05-26 18:09:41 UTC
Created attachment 1162235 [details]
File: dmesg

Comment 2 Joonas Kylmälä 2016-07-08 22:47:33 UTC
Created attachment 1177791 [details]
Lenovo ThinkPad x260 dmesg

Looks like I have this very same problem on Lenovo ThinkPad x260. I attached my dmesg and it shows the same warning/trace. I'm running Fedora 24 with the latest updates and used powertop program to change the settings the program offers for better battery life (there was some problems with cpu/something related to it not going over some C2 state if not using powertop).

See also https://bugs.freedesktop.org/show_bug.cgi?id=95646, they are also trying to solve the same bug.

Comment 3 Hans de Goede 2016-07-12 16:38:56 UTC
*** Bug 1342722 has been marked as a duplicate of this bug. ***

Comment 4 Hans de Goede 2016-07-12 16:39:22 UTC
*** Bug 1325020 has been marked as a duplicate of this bug. ***

Comment 5 Hans de Goede 2016-07-12 16:39:26 UTC
*** Bug 1347681 has been marked as a duplicate of this bug. ***

Comment 6 Hans de Goede 2016-07-12 16:46:48 UTC
Also see:

https://bugs.freedesktop.org/show_bug.cgi?id=96214
https://bugzilla.kernel.org/show_bug.cgi?id=120451

And this is a potential fix:
https://patchwork.freedesktop.org/patch/97995/

I'm building a kernel to test this now.

Comment 7 Hans de Goede 2016-07-12 19:20:51 UTC
(In reply to Hans de Goede from comment #6)
> I'm building a kernel to test this now.

Unfortunately the fix does not work.

Comment 8 Hans de Goede 2016-07-14 12:43:22 UTC
Ok, I've attached a new fix to:
https://bugs.freedesktop.org/show_bug.cgi?id=96214

And I've build a test-kernel with this fix, which fixes things for me:
http://koji.fedoraproject.org/koji/taskinfo?taskID=14883873

If you want to test this kernel yourself, grab it while its hot, this is a scratch build so it will be removed in a couple of days.

p.s.

I'm going on vacation for the coming 2 weeks, so if I'm quiet that is why.

Comment 9 Hans de Goede 2016-07-15 09:37:41 UTC
*** Bug 1352718 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2016-07-29 12:20:44 UTC
kernel-4.6.5-200.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-754e4768d8

Comment 11 Fedora Update System 2016-07-29 12:21:30 UTC
kernel-4.6.5-300.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-30e3636e79

Comment 12 Fedora Update System 2016-07-30 19:27:09 UTC
kernel-4.6.5-200.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-754e4768d8

Comment 13 Fedora Update System 2016-07-30 19:27:32 UTC
kernel-4.6.5-300.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-30e3636e79

Comment 14 Jason Birch 2016-08-08 03:35:35 UTC
I used to run into this one when connecting a DP 1.2 monitor to a USB 3 dock, which would result in a hard lock up.

On my system, using 4.6.5-300.fc24.x86_64 seems to push past these problems. While there's still a (different) panic, I no longer have a hard-lock of my system.

Thanks!

Comment 15 Fedora Update System 2016-08-08 20:25:29 UTC
kernel-4.6.5-300.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2016-08-08 23:52:41 UTC
kernel-4.6.5-200.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.