This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 132523 - freetype needs BuildRequires: xorg-x11-devel
freetype needs BuildRequires: xorg-x11-devel
Status: CLOSED DUPLICATE of bug 79688
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Owen Taylor
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-14 09:37 EDT by Oliver Falk
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2004-09-14 09:37:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
[ ... ]
Xlib.h: No such file or directory
[ ... ]
Xutil.h: No such file or directory
[ ... ]
keysym.h: No such file or directory

Those files come from xorg-x11-devel, so freetype should depend on
this files or on the package xorg-x11-devel 

Version-Release number of selected component (if applicable):
2.1.9-1

How reproducible:
Always

Steps to Reproduce:
Try building freetype without xorg-x11-devel installed

Additional info:
Comment 1 Owen Taylor 2004-09-14 09:41:00 EDT
Quite non-trivial to fix; it's no just a question of adding
the BuildRequires since there is a xorg BuildRequires FreeType
BuildRequires xorg loop. 

You basically have to rewrite the make rules for ft2demos
so they can be build in a separate package.


*** This bug has been marked as a duplicate of 79688 ***
Comment 2 Oliver Falk 2004-09-14 10:10:40 EDT
Yes, I know this loop, I do have this problem currently, because I'm 
trying to recompile the fedora development tree for my alpha ds10. :-/

Do we really need the ft2demos? If we do not, we could just kick 'em 
out!? A seperate package would also make sense to me...
Comment 3 Owen Taylor 2004-09-14 10:18:01 EDT
Certainly for a bootstrap, what you want to do is to hack
the freetype package to omit the ft2demos.

I don't want to drop them from the distro entirely because
they are pretty useful when I'm trying to debug a font problem
on someone's computer ... ftview allows separating out the
behavior of FreeType from all the stuff higher in the text
rendering stack. 

They can't be (easily) split into a separate package because
they are set up to only build when unpacked into the freetype
source tree.
Comment 4 Red Hat Bugzilla 2006-02-21 14:05:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.