Bug 79688 - freetype ft2demos BuildRequires XFree86-devel
freetype ft2demos BuildRequires XFree86-devel
Status: CLOSED CANTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: freetype (Show other bugs)
1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Carl Worth
Brock Organ
:
: 110600 132523 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-14 22:02 EST by Warren Togami
Modified: 2006-10-18 15:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 15:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-12-14 22:02:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
freetype-2.1.2-12's ft2demos fails compilation without XFree86-devel.
Comment 1 Mike A. Harris 2002-12-17 18:08:05 EST
While that may be true......
It creates a build dependancy loop.  ;o/

freetype package Buildrequires XFree86-devel
XFree86 package Buildrequires freetype-devel

ick

The only way to avoid that is to split out freetype-demos into it's
own package.  Not really that big of a deal IMHO, but I know some folk
around here want to stuff 90 rpms into one.  ;o)
Comment 2 Warren Togami 2002-12-17 19:53:07 EST
Since the build will fail anyway, might as well save the developer some time and
abort early?

--- freetype.spec.orig  2002-12-17 14:45:09.000000000 -1000
+++ freetype.spec       2002-12-17 14:52:20.000000000 -1000
@@ -97,6 +97,11 @@


 %prep
+if [ ! -f /usr/X11R6/bin/imake ]; then
+    echo "Please install XFree86-devel.  Aborting."
+    exit 127
+fi
+
 %setup -q -b 1 -a 2 -a 3

 %patch0   -p0 -b .ft1-libtool
Comment 3 Owen Taylor 2003-01-09 17:33:18 EST
Splitting the freetype-demos package out is almost certainly the right
fix. I'm not all that happy with the "stuff a bunch of tarballs into
a single SRPM" approach that the freetype package takes to start
with. I think I'm just going to leave things as is, until I have
a chance to split it.
Comment 4 Owen Taylor 2003-06-09 18:28:00 EDT
However, splitting ft2demos out is non-trivial, since it requires writing 
entirely new makefiles for ft2demos, since the current ones depend
on building in a subdirectory of freetype. (Well, we could have
a ft2demos package that includes the freetype sources and builds
them, and then throws them away, but that's even more unpleasant
than the current.)
Comment 5 Miloslav Trmac 2004-02-10 16:34:43 EST
*** Bug 110600 has been marked as a duplicate of this bug. ***
Comment 6 Owen Taylor 2004-09-14 09:41:07 EDT
*** Bug 132523 has been marked as a duplicate of this bug. ***
Comment 7 Alexander Kain 2005-02-08 21:05:15 EST
This is still true for FC3, where it needs xorg-x11-devel, of course.
Comment 8 Bill Nottingham 2006-08-07 21:37:43 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 9 Bill Nottingham 2006-10-18 15:27:57 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.