Bug 132541 - Pound key on UK keyboard inserts two chars A�
Pound key on UK keyboard inserts two chars A�
Status: CLOSED DUPLICATE of bug 138618
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: 133486 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-09-14 12:25 EDT by David W. Legg
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-28 09:04:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David W. Legg 2004-09-14 12:25:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)

Description of problem:
With a UK keyboard using Fedora Core 2 containing OOo V1.1.1 and also
with the OOo V1.1.2 from Fedora Core 3 test 3, pressing the pound key
(�, that is, shift-3) to insert a currency symbol in the Writer and
Spread sheet actuall inserts 2 characters instead of 1. The first char
is a capital A with a hat on it (circumflex). The second is the
desired pound character (shift-3). Obviously, only one char should be
generated. This is entirely reproduceable in both versions of OOo.
Have only tested  it on FC2, though.

Version-Release number of selected component (if applicable):
openoffice-1.1.2 all builds

How reproducible:

Steps to Reproduce:
1. Start OOo
2. Press shift-3
3. Watch A(+hat)� appear

Actual Results:  2 chars inserted instead of 1.
First char incorrect. Second char correct.

Expected Results:  Just a pound sign should appear.

Additional info:
Comment 1 Caolan McNamara 2004-09-15 06:52:33 EDT
That's odd, I have that keyboard and I get a single "£" with 1.1.2-3.
Admittedly I'm running an up to date FC3test. What's the output of
"locale" run from a terminal, and I assume that OOo is the only
application that shows this behaviour ?
Comment 2 David W. Legg 2004-09-15 14:15:41 EDT
[root@aldebaran log]# locale
[root@aldebaran log]#

This is on FC2 which runs OOo 1.1.1.

Yes, OOo, is the only one, but both Writer and Spreadsheet do it.

I also have a friend with a fully updated FC2 that has noticed the
same problem.
Comment 3 Dan Williams 2004-09-15 14:28:27 EDT
do you guys happen to have any input servers running, like IIIMF
(htt_server) or kinput2?  There is an issue with double-byte input
when running these, which was fixed on later builds of OOo.

To test:

1) open a terminal
2) type 'tcsh'
3) type 'setenv XMODIFIERS "@im=none"'
4) type /usr/bin/oowriter

And see if that helps...  Please report back what the result is.

Comment 4 Dan Williams 2004-09-15 14:36:54 EDT
I'm unable to reproduce this bug on openoffice.org-1.1.2-3, either
with htt_server running or without.  My procedure:

1) set LANG to en_GB.UTF-8
2) from the terminal, "gkb_xmmap uk"
3) /usr/bin/oowriter
4) Type shift-3
5) Get correct Pound sign
Comment 5 David W. Legg 2004-09-17 16:34:26 EDT
Have htt_server running (as out of the box in FC2).
None of the others.

1) open a terminal
2) type 'tcsh'
3) type 'setenv XMODIFIERS "@im=none"'
4) type /usr/bin/oowriter

produced the same result (A with a hat followed by a pound sign).

That was with openoffice.org-1.1.1-4 on FC2.
Comment 6 David W. Legg 2004-09-17 16:37:32 EDT
When I try:

1) set LANG to en_GB.UTF-8
2) from the terminal, "gkb_xmmap uk"
3) /usr/bin/oowriter
4) Type shift-3
5) Get correct Pound sign

I still get the double characters (A-hat pound).

Let me know if I can try anything else.

BTW. OOo is really looking quite superb nowadays. Just the odd gremlin
to contend with. Cheers.:)
Comment 7 Dan Williams 2004-09-25 15:31:20 EDT
This issue should be fixed with OOo 1.1.1-6 and later...  Any way you
could test with the OOo 1.1.2 in Rawhide?
Comment 8 David W. Legg 2004-09-25 17:29:00 EDT
I tried it with 1.1.2-3 on FC2 and it had the bug.
Are saying it has been fixed between 1.1.2-3 and 1.1.2-6?
Comment 9 Dan Williams 2004-09-28 16:42:15 EDT
*** Bug 133486 has been marked as a duplicate of this bug. ***
Comment 10 sverrejon john 2004-09-28 18:29:01 EDT
After trying this:
2) type 'tcsh'
3) type 'setenv XMODIFIERS "@im=none"'

the signs changed, but øæå doesn't work )=
Comment 11 David W. Legg 2005-01-03 15:24:44 EST
I have just tried OOo 1.1.2-3 in FC3 and the problem persists, ie the
pound key still generates 2 characters, but only under KDE.

I also notice thatif I turn off the iiimf service, the problem goes away.
Hope this helps some-one ...
Comment 12 Petr Šimon 2005-01-21 05:14:14 EST
1. LANG=en_GB.UTF-8, gkb_xmmap uk
2. when lounching OOo another small window titled "IME Status" appears, which
provides input methods that are available for all GTK apps, actually more.
3. Eperiment: zh_CN.UTF-8, gkb_xmmap uk, problem was gone. And even the "IME
Status" window did not appear.
4. Same problem with cs_CZ.UTF-8 and czech keyboard
5. only in KDE
Comment 13 Petr Šimon 2005-01-21 05:43:51 EST
As I pointed in out in #138183, might be UTF-8 related problem. en_GB.iso88591
works fine.
Comment 14 Dan Williams 2005-02-28 12:08:35 EST
Most likely a dupe of Bug 138618, stopping the "iiim" service seems to

*** This bug has been marked as a duplicate of 138618 ***
Comment 15 Caolan McNamara 2005-04-28 09:04:11 EDT
close as duplicate

Note You need to log in before you can comment on or make changes to this bug.