Bug 1325630 - Error in /var/lib/glusterd/groups/virt
Summary: Error in /var/lib/glusterd/groups/virt
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.7.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaushal
QA Contact:
URL:
Whiteboard: glusterd
: 1332550 (view as bug list)
Depends On:
Blocks: 1329895
TreeView+ depends on / blocked
 
Reported: 2016-04-10 06:25 UTC by xrobau
Modified: 2016-05-03 13:40 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.11
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1329895 (view as bug list)
Environment:
Last Closed: 2016-04-19 07:13:37 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description xrobau 2016-04-10 06:25:48 UTC
Description of problem:
When running the command "gluster volume set <volname> group virt" it fails with:
volume set: failed: option : eager-lock does not exist
Did you mean eager-lock?

This is because there is now a 'disperse.eager-lock', so it needs to be explicitly named as 'cluster.eager-lock' in the virt group

Version-Release number of selected component (if applicable):
3.7.10-1

How reproducible:
Always

Steps to Reproduce:
1. As above
2.
3.

Actual results:
As above

Expected results:
volume set: success

Additional info:

Changing the line 'eager-lock=enable' to 'cluster.eager-lock=enable' resolves this

Comment 1 SATHEESARAN 2016-04-11 07:29:45 UTC
The cause of this issue is that the options and values listed in the virt profile file doesn't include the domain of the option.

Its always good to have key along with its domain in the format :
"domain.key=value"

Comment 2 SATHEESARAN 2016-04-11 17:36:40 UTC
The patch - http://review.gluster.org/#/c/13958/ - fixes this issue

Comment 3 Vijay Bellur 2016-04-13 03:29:00 UTC
REVIEW: http://review.gluster.org/13958 (extras: Add namespace for options in group-virt.example) posted (#3) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)

Comment 4 Vijay Bellur 2016-04-13 13:00:35 UTC
COMMIT: http://review.gluster.org/13958 committed in release-3.7 by Kaushal M (kaushal@redhat.com) 
------
commit 2b7ae34eff4ed00f15661cf1ca5b2ee07a1d93bd
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Fri Apr 8 21:59:53 2016 -0400

    extras: Add namespace for options in group-virt.example
    
    Commit 23ccabbeb7 introduced a new key "disperse.eager-lock" which
    causes a conflict with key "cluster.eager-lock" when option is used
    without the qualifying namespace. group-virt.example which gets
    installed as /var/lib/glusterd/ groups/virt contains options without
    namespace qualifiers. This patch adds the appropriate namespace to all
    options in group-virt.example.
    
    Change-Id: I2c09dd10d44138410d889ddeb805f01c641c6780
    BUG: 1325630
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/13929
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13958
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Kaushal M <kaushal@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 5 Kaushal 2016-04-19 07:13:37 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.11, please open a new bug report.

glusterfs-3.7.11 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026321.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Atin Mukherjee 2016-05-03 13:40:14 UTC
*** Bug 1332550 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.