Bug 1329895 - eager-lock should be used as cluster.eager-lock in /var/lib/glusterd/group/virt file as there is a new option disperse.eager-lock
Summary: eager-lock should be used as cluster.eager-lock in /var/lib/glusterd/group/vi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: rhgs-3.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.1.3
Assignee: Pranith Kumar K
QA Contact: SATHEESARAN
URL:
Whiteboard: glusterd
Depends On: 1325630
Blocks: 1311817
TreeView+ depends on / blocked
 
Reported: 2016-04-24 12:23 UTC by SATHEESARAN
Modified: 2016-09-17 16:46 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.9-3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1325630
Environment:
RHEV-RHGS Integration
Last Closed: 2016-06-23 05:19:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1240 0 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 Update 3 2016-06-23 08:51:28 UTC

Description SATHEESARAN 2016-04-24 12:23:26 UTC
Description of problem:
------------------------
While optimizing the storage for virt-store, the options available in the file /var/lib/glusterd/groups/virt will applied on the volume.

When running the command "gluster volume set <volname> group virt" it fails with:
volume set: failed: option : eager-lock does not exist
Did you mean eager-lock?

This is because there is now a 'disperse.eager-lock', so it needs to be explicitly named as 'cluster.eager-lock' in the virt group

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1.3 nightly ( glusterfs-3.7.9-2.el7rhgs )

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Apply the group virt options on the volume
(i.e) gluster volume set <vol> group virt

Actual results:
---------------
Not all the options are set on the volume, and the tagging the volume with group virt results in error

Expected results:
-----------------
All the options in the virt file should be set on the volume successfully

Additional info:
----------------
Changing the line 'eager-lock=enable' to 'cluster.eager-lock=enable' resolves this

Root cause
----------
The cause of this issue is that the options and values listed in the virt profile file doesn't include the domain of the option.

Its always good to have key along with its domain in the format :
"domain.key=value"

The patch - http://review.gluster.org/#/c/13958/ - fixes this issue

The following commit should be backported to RHGS 3.1.3 branch
COMMIT: http://review.gluster.org/13958 committed in release-3.7 by Kaushal M (kaushal@redhat.com) 
------
commit 2b7ae34eff4ed00f15661cf1ca5b2ee07a1d93bd
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Fri Apr 8 21:59:53 2016 -0400

    extras: Add namespace for options in group-virt.example
    
    Commit 23ccabbeb7 introduced a new key "disperse.eager-lock" which
    causes a conflict with key "cluster.eager-lock" when option is used
    without the qualifying namespace. group-virt.example which gets
    installed as /var/lib/glusterd/ groups/virt contains options without
    namespace qualifiers. This patch adds the appropriate namespace to all
    options in group-virt.example.
    
    Change-Id: I2c09dd10d44138410d889ddeb805f01c641c6780
    BUG: 1325630
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/13929
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13958
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Kaushal M <kaushal@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 1 Milind Changire 2016-04-25 06:23:54 UTC
approved with devel_ack+

Comment 2 Kaushal 2016-04-25 08:52:00 UTC
https://code.engineering.redhat.com/gerrit/72923 Change posted for review.

Comment 5 SATHEESARAN 2016-05-02 17:32:27 UTC
Tested with the installation of glusterfs-3.7.9-3.el7rhgs

The fresh installation adds the /var/lib/glusterd/groups/virt file as a collection of namespace.keys=value

Also when this file is not altered by the user/customer, then older file gets updated to newer one

Comment 6 Atin Mukherjee 2016-05-03 11:27:58 UTC
Assigning it to Pranith for the doc text.

Comment 9 errata-xmlrpc 2016-06-23 05:19:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240


Note You need to log in before you can comment on or make changes to this bug.