Bug 132564 - Add back redhat-web.desktop with NoDisplay=true
Add back redhat-web.desktop with NoDisplay=true
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: htmlview (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
: 136062 (view as bug list)
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-14 14:59 EDT by Seth Nickell
Modified: 2013-04-02 00:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 21:45:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Quick patch (1.63 KB, patch)
2004-09-22 18:24 EDT, Jonathan Blandford
no flags Details | Diff

  None (edit)
Description Seth Nickell 2004-09-14 14:59:35 EDT
We should remove all .desktop files from htmlview, never again to
return. It creates duplicate entries for apps, and doesn't really help
anything out.
Comment 1 Mark McLoughlin 2004-09-17 03:53:45 EDT
jrb: don't forget to fix the panel :)
Comment 2 Jonathan Blandford 2004-09-22 18:24:36 EDT
Created attachment 104154 [details]
Quick patch
Comment 3 Mark McLoughlin 2004-09-24 05:05:31 EDT
And when someone changes their preferred browser?

Couldn't we not add back the .desktop file and set NoDisplay=true?
Comment 5 Bryan W Clark 2004-09-24 12:46:00 EDT
Changing the items (either their name or the fact that they display)
that appear in the menu would be a bad thing.  Users obviously may
change their default browser to be Firefox, but that's because they
know the different between the browsers and will be fine with
launching "Firefox Web Browser".

Of course on the flip side, the panel launcher would probably do
better to be an htmlview launcher.  Adding and removing launchers from
the panel isn't the easiest thing right now and I wouldn't want to
expect that people do it when they change their default browser.
Comment 6 Ray Strode [halfline] 2004-09-29 02:55:40 EDT
Note that having htmlview in a desktop file causes difficult problems
because not all browsers are created equal.  For instance the value of
StartupNotify= can't really be hard coded.

If redhat-web is important to have then what I think what we really
need is a htmlview type program that launches desktop files instead of
programs directly.  

I guess this would mean changing the Preferred Applications hard coded
list of browser (name, command) pairs to a list of known desktop
files.  For custom browers, a user specific desktop entry would need
to be written to ~/.local/share/applications like eel does when
changing default applications for mime types.   Then the currently
selected browser's desktop file would be stored in gconf.
 
  
Comment 7 Warren Togami 2004-10-13 05:51:57 EDT
Just to clarify, both redhat-web.desktop and redhat-email.desktop to
launch htmlview and launchmail scripts are wanted?  (Yes it does work,
only caveat being the StartupNotify thing, which can be easily worked
around for 99.9% cases.)
Comment 8 Jonathan Blandford 2004-10-13 15:06:50 EDT
Mark convinced me that we should add it back, just for the panel.
Comment 9 Warren Togami 2004-10-15 00:41:21 EDT
Both redhat-web.desktop and redhat-email.desktop to launch each
respective Preferred Application?
Comment 10 Alexander Larsson 2004-10-15 09:18:19 EDT
redhat-web.desktop is the default handler for .html files in gnome. Is
this right? Will this file point to the default web browser?
Comment 11 Seth Nickell 2004-10-15 12:48:34 EDT
I would rather not have this sort of one off hack set as the default
handler...but jrb probably has a better sense here?
Comment 12 Jonathan Blandford 2004-10-15 17:28:58 EDT
After talking with mark, the plan is to add those desktop files back
with NoDisplay=True set.  They will just be used by the panel. 
redhat-web.desktop will launch htmlview, and the redhat-email.desktop
will just be a symlink to evolution.  They won't appear in the menus
at all.
Comment 13 Jonathan Blandford 2004-10-18 21:45:14 EDT
Done.
Comment 14 Marco Pesenti Gritti 2004-10-28 07:02:12 EDT
*** Bug 136062 has been marked as a duplicate of this bug. ***
Comment 15 Orion Poplawski 2004-11-30 19:16:18 EST
Just another comment -  we install our browsers to a shared NFS
directory and have been counting on the htmlview .desktop icons to
launch the default browser.  It's not a big deal for me to modify the
.desktop icons in our kickstart scripts so they appear in the menus
(though perhaps these would be lost if newer versions of the htmlview
rpm are released?).

Anyways, I'm glad you kept the .desktop files.

Note You need to log in before you can comment on or make changes to this bug.