Bug 1325682 - [RFE] [Neutron] Support for QoS DSCP markings
Summary: [RFE] [Neutron] Support for QoS DSCP markings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 10.0 (Newton)
Assignee: Miguel Angel Ajo
QA Contact: Eran Kuris
URL:
Whiteboard:
: 1329350 (view as bug list)
Depends On:
Blocks: 1334442 1335593 1371857
TreeView+ depends on / blocked
 
Reported: 2016-04-10 15:52 UTC by Nir Yechiel
Modified: 2017-03-22 14:15 UTC (History)
14 users (show)

Fixed In Version: openstack-neutron-9.0.0-0.20160907193737.dc6508a.el7ost
Doc Type: Enhancement
Doc Text:
With this update, IP traffic can be managed by DSCP marking rules attached to QoS policies, which are in turn applied to networks and ports. This was added because different sources of traffic may require different levels of prioritisation at the network level, especially when dealing with real-time information, or critical control data. As a result, the traffic from the specific ports and networks can be marked with DSCP flags. Note that only Open vSwitch is supported in this release.
Clone Of:
Environment:
Last Closed: 2016-12-14 15:32:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 190285 None None None 2016-04-10 15:55:13 UTC
Red Hat Bugzilla 1329350 None None None Never
Launchpad 1468353 None None None 2016-04-10 15:52:24 UTC

Internal Links: 1329350

Description Nir Yechiel 2016-04-10 15:52:25 UTC
Description of problem:

The QoS API introduces an interface to configure QoS policies
to neutron ports/networks. This proposal talks about enhancing the existing QoS API by adding DSCP marking support. The functionality will make use Open vSwitch for adding DSCP marks to outbound network traffic.

Comment 3 Joe Donohue 2016-06-07 19:10:13 UTC
*** Bug 1329350 has been marked as a duplicate of this bug. ***

Comment 4 Nir Yechiel 2016-09-13 05:28:13 UTC
Note: support for this feature is currently (as of Newton/RHOSP 10) available for VLAN network type only, tunneling (VXLAN) will follow.

Comment 5 Toni Freger 2016-09-19 11:28:40 UTC
Hi Assaf,

Shouldn't it be on ON_QA already?

Comment 6 Assaf Muller 2016-09-19 11:58:00 UTC
Miguel is there a reason not to flip this to MODIFIED? Do latest OSP 10 puddles contain the necessary code?

Comment 15 errata-xmlrpc 2016-12-14 15:32:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.