Bug 132575 - set sound levels on first boot
set sound levels on first boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 152246 (view as bug list)
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-14 15:43 EDT by Bryan W Clark
Modified: 2014-03-16 22:48 EDT (History)
6 users (show)

See Also:
Fixed In Version: alsa-utils-1.0.8-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-01 17:26:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a silly initial volume setter (2.04 KB, patch)
2004-11-29 17:41 EST, Bill Nottingham
no flags Details | Diff
slightly better version, FWIW (1.96 KB, patch)
2004-11-29 22:43 EST, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Bryan W Clark 2004-09-14 15:43:09 EDT
Here is the situation:

After a fresh install, upon first boot a users sound card levels, PCM
and Volume, are both at zero.  When the user logs in they have to
figure out how to turn the PCM and Volume sound up via the sound
applet which is very difficult.  The sound applet is being worked on
upstream to improve this situation, however the fact that it is
difficult to use is not the whole problem.  The real problem is that
we don't have sounds on by default so that music playing and other
sounds from things like IM work out of the box, as intended.  The
default sound level should not loud but at a reasonable level to start
with and let the user change via the applet from there.

Setting the default level to 75% on both the Volume and PCM will bring
the sound to where it isn't loud or obnoxious on some cards and will
turn it on enough for people to hear it working and have them adjust
it up or down from there.

Not sure if this is the correct component for filing this bug, feel
free to move this to a more appropriate component.
Comment 1 Bill Nottingham 2004-09-14 17:11:10 EDT
s-c-soundcard (run in firstboot) sets a default, I believe.
Comment 2 sangu 2004-09-18 22:23:00 EDT
cat /etc/modprobe.conf

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.0rc2 ---
alias char-major-116* snd
alias snd-card-0 snd-emu10k1
# OSS/Free portion
alias char-major-14* soundcore
alias sound-slot-0 snd-card-0
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-emu10k1 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-emu10k1

---

initscripts-7.80-1

After rebooting, pcm value is always "0" in gnome-volume-control. So
no sound. 
Comment 3 Bryan W Clark 2004-09-24 03:19:39 EDT
switching to s-c-s
Comment 4 Féliciano Matias 2004-09-27 07:12:01 EDT
Seems duplicate of :
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=133535
Comment 5 Bryan W Clark 2004-09-29 17:18:10 EDT
This does not appear to be a dup of the bug 133535 mentioned in comment 4

This bug is about the sound levels being set on the boot up after a
first install.
Comment 6 Féliciano Matias 2004-09-29 19:36:09 EDT
I look at the source of system-config-soundcard and it set the mixer
setting only if "Play test sound" is clicked. Overless the mixer stay
muted.
Comment 7 Bastien Nocera 2004-09-30 20:08:35 EDT
We need to set the mixer states even if the no tests are being run.

We also need to be careful not to change the states if this isn't the
first run, or set the volume/unmute if need be when running the config
tool in a normal desktop.
Comment 8 Féliciano Matias 2004-09-30 21:08:01 EDT
> We also need to be careful not to change the states if this isn't the
first run

Useless since only root can launch system-config-soundcard.
system-config-soundcard is use when there is something broken or
changed (new sound card).
Comment 9 Bastien Nocera 2004-10-01 06:01:44 EDT
Then this bug shouldn't be in system-config-soundcard...
I'll let Bill handle that one.
Comment 10 Féliciano Matias 2004-10-01 06:55:30 EDT
Again...  This bug seems a duplicate of #133535 . Perhaps I am wrong.
But this bug and #133535 should be in udev.

If this bug append without a reboot (as stated by comment #5) then
initscripts (/etc/rc.d/rc.sysinit) don't involve here.
Comment 11 Bill Nottingham 2004-10-01 12:06:43 EDT
No, it's not fully a duplicate.

133535 is about the current saved volume not being restored.

This bug is about it not being *set* anywhere to begin with.

That either needs done at initial 'configuration' with s-c-soundcard,
or at the alsa-library (ick) or desktop levels.
Comment 12 Bryan W Clark 2004-10-01 12:44:00 EDT
Yes, Bill is 100% correct.  This is not fully a duplicate.  

I'm hoping Bastien can add something to s-c-soundcard for first boot
that initializes the PCM and Main Volumes to be about 75% or so.  
Comment 13 Bryan W Clark 2004-10-08 17:04:39 EDT
Has this been fixed?  In the last test install sounds was set at 75%
after a fresh install.
Comment 14 Alexander Larsson 2004-10-18 10:04:00 EDT
It sure wasn't fixed for me. Fresh install. Both Master an PCM was
zero volume and muted.
Comment 15 Ronny Buchmann 2004-10-19 16:53:11 EDT
Also Headphone volume (if mixer present) should be set to some level,
this is sometimes used on laptops instead of Master.
Comment 16 Seth Nickell 2004-10-21 17:29:05 EDT
It appears to have regressed. It was working for a couple weeks, but
the latest test installs appear to be broken again.
Comment 17 Bill Nottingham 2004-10-22 23:59:15 EDT
The only code that exists currently to unmute the default alsa config
is in s-c-soundcard, in the sound test program.
Comment 18 Bill Nottingham 2004-11-29 17:41:44 EST
Created attachment 107580 [details]
a silly initial volume setter

The attached will, when run:

a) set all playback channels to 75%
b) mute all capture channels, except for CD

We could run this at some point in the first boot process, I suppose. But it
would run into the same issues as s-c-soundcard in making sure it's run in all
cases.

Moreover, it's rather late for this sort of change, and there's no guarantee
that this sort of config won't make someone's ears bleed on some oddly-wired
sound card.
Comment 19 Bill Nottingham 2004-11-29 22:43:11 EST
Created attachment 107603 [details]
slightly better version, FWIW
Comment 20 Bryan W Clark 2005-01-24 12:28:07 EST
Bill: Did this get into rawhide yet?  I don't want bug reports of ears
bleeding, however I'd really like to get something like this in.  Most
distros (*cough* Ubuntu and NLD) have sound at a reasonable level
working from first boot.
Comment 21 Bryan W Clark 2005-01-24 12:29:42 EST
Oh and we should definitely email test-list or something to ask as
many people as possible to try this out once we get it in.  Hopefully
we'll get it smoothed out before FC4.
Comment 22 Bill Nottingham 2005-01-25 00:49:57 EST
It's not in rawhide because it's not really obvious where you'd want
to run it.
Comment 23 Bryan W Clark 2005-01-25 20:08:17 EST
Maybe I'm confused, I thought this was to be run during first boot (
i.e. after a fresh install ).  Initializing the persons sounds levels
to a value where when they play something sound will actually come out
instead of leaving the levels at zero and leaving them to hunt down
PCM and Master volume settings.  This only needs to happen at first
boot, after that sound is saved and restored on shutdown/startup, correct?
Comment 24 Bill Nottingham 2005-01-25 20:38:32 EST
CC'ing firstboot maintaner. I suppose it could be grafted into
firstboot, if we assume that firstboot isn't going to fail/be skipped.

We could also do something really gross like run it on module load for
any card that *doesn't* have a saved state. Not sure if that would
surprise people, though.
Comment 25 Bill Nottingham 2005-04-01 17:26:06 EST
OK, alsa-utils-1.0.8-4 has changed the default script that restores sound
volumes on module load to unmute the playback channels if there is no saved
config to restore.
Comment 26 Need Real Name 2005-04-08 17:15:57 EDT
*** Bug 152246 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.