Bug 1325826 - Too many log messages showing inode ctx is NULL for 00000000-0000-0000-0000-000000000000
Summary: Too many log messages showing inode ctx is NULL for 00000000-0000-0000-0000-0...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix-acl
Version: 3.7.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On: 1324338 1325822
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-11 10:19 UTC by Vijaikumar Mallikarjuna
Modified: 2016-05-11 22:49 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.11
Doc Type: Bug Fix
Doc Text:
Clone Of: 1325822
Environment:
Last Closed: 2016-04-19 07:13:37 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-11 10:20:30 UTC
REVIEW: http://review.gluster.org/13962 (posix_acl: create inode ctx for posix_acl_get) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Vijay Bellur 2016-04-11 11:21:02 UTC
REVIEW: http://review.gluster.org/13962 (posix_acl: create inode ctx for posix_acl_get) posted (#2) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Vijay Bellur 2016-04-14 09:01:38 UTC
REVIEW: http://review.gluster.org/13962 (posix_acl: create inode ctx for posix_acl_get) posted (#3) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Vijay Bellur 2016-04-16 02:00:20 UTC
COMMIT: http://review.gluster.org/13962 committed in release-3.7 by Kaushal M (kaushal@redhat.com) 
------
commit 1c62ca12df86eedf130de679ac99638a9d0ad82d
Author: vmallika <vmallika@redhat.com>
Date:   Mon Apr 11 15:44:16 2016 +0530

    posix_acl: create inode ctx for posix_acl_get
    
    This is a backport of http://review.gluster.org/13961
    
    > Change-Id: Ibe5b00cd4b5d896133adc61f65094d783c492ed4
    > BUG: 1325822
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I6be941044ea430913bb950c202f65a1c642d7ae4
    BUG: 1325826
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13962
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 5 Kaushal 2016-04-19 07:13:37 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.11, please open a new bug report.

glusterfs-3.7.11 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026321.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.