Bug 1325870 - dbus-daemon fails to close correct file descriptors
Summary: dbus-daemon fails to close correct file descriptors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dbus
Version: 7.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: David King
QA Contact: Desktop QE
Milan Navratil
URL:
Whiteboard:
Depends On:
Blocks: 1203710 1348830 1364088
TreeView+ depends on / blocked
 
Reported: 2016-04-11 12:06 UTC by Siteshwar Vashisht
Modified: 2019-10-10 11:50 UTC (History)
15 users (show)

Fixed In Version: dbus-1.6.12-14.el7
Doc Type: Release Note
Doc Text:
The *dbus-daemon* service no longer becomes unresponsive due to leaking file descriptors Previously, the *dbus-daemon* service incorrectly handled multiple messages containing file descriptors if they were received in a short time period. As a consequence, *dbus-daemon* leaked file descriptors and became unresponsive. A patch has been applied to correctly handle multiple file descriptors from different messages inside *dbus-daemon*. As a result, *dbus-daemon* closes and passes file descriptors correctly and no longer becomes unresponsive in the described situation.
Clone Of:
: 1348830 (view as bug list)
Environment:
Last Closed: 2016-11-04 06:41:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2453 normal SHIPPED_LIVE dbus bug fix and enhancement update 2016-11-03 14:04:29 UTC
Red Hat Knowledge Base (Solution) 2220531 None None None 2016-06-21 02:49:41 UTC

Description Siteshwar Vashisht 2016-04-11 12:06:28 UTC
Description of problem:
dbus-daemon fails to close correct file descriptors.

Version-Release number of selected component (if applicable):
dbus-1.6.12-11.el7.x86_64

How reproducible:
Always

Actual results:
'dbus-daemon: Failed to close file descriptor: Could not close fd' messages appear in journal logs


Expected results:
Correct file descriptors should be closed.

Additional info:

This is a known bug which was fixed through https://cgit.freedesktop.org/dbus/dbus/commit/?id=07f4c12efe3b9bd45d109bc5fbaf6d9dbf69d78e

Comment 3 neil 2016-05-03 19:58:49 UTC
We're hitting this bug often enough that dbus-daemon hits the open fd limit (2144 by default). Once this happens, dbus-daemon starts chewing through 100% CPU time of a core until dbus-daemon is restarted.

In a cluster of 8 machines with the same workload and same uptime we've observed a wide variance in the number of "leaked" fds per hour, ranging from ~0.42 fds/hour to 1.38 fds/hour. However, all machines are leaking fds over time, just at different rates.

Observed with dbus-1.6.12-13.el7.x86_64.

Comment 6 neil 2016-05-04 14:37:49 UTC
It would be ideal if this could be fixed in time for RHEL 7.3.

Comment 19 errata-xmlrpc 2016-11-04 06:41:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2453.html


Note You need to log in before you can comment on or make changes to this bug.