Bug 1348830 - dbus-daemon fails to close correct file descriptors
Summary: dbus-daemon fails to close correct file descriptors
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dbus
Version: 7.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: David King
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords: Regression, ZStream
Depends On: 1325870
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-22 07:49 UTC by Marcel Kolaja
Modified: 2016-10-14 08:26 UTC (History)
13 users (show)

(edit)
Previously, the dbus-daemon service incorrectly handled multiple messages containing file descriptors if they were received in a short time period. As a consequence, dbus-daemon leaked file descriptors and became unresponsive. A patch has been applied to correctly handle multiple file descriptors from different messages inside dbus-daemon. As a result, dbus-daemon closes and passes file descriptors correctly and no longer becomes unresponsive in the described situation.
Clone Of: 1325870
(edit)
Last Closed: 2016-08-02 18:26:15 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1444 normal SHIPPED_LIVE dbus bug fix update 2016-08-02 22:20:55 UTC
Red Hat Knowledge Base (Solution) 2220531 None None None 2016-06-22 07:49 UTC

Description Marcel Kolaja 2016-06-22 07:49:19 UTC
This bug has been copied from bug #1325870 and has been proposed
to be backported to 7.2 z-stream (EUS).

Comment 7 errata-xmlrpc 2016-08-02 18:26:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1444.html


Note You need to log in before you can comment on or make changes to this bug.