Bug 132649 - Before RPM Update the redhat-config-printer doesn't start
Before RPM Update the redhat-config-printer doesn't start
Status: CLOSED DUPLICATE of bug 131563
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-15 11:05 EDT by Daniel Romo
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Romo 2004-09-15 11:05:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
When I try to start the Printer Manager on Gnome, it doesn't start, so
I  execute it from terminal mode, and I get this messenge:

[root@RHES root]# redhat-config-printer
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 945, in ?
    queueTree()
  File "/usr/share/printconf/util/queueTree.py", line 102, in __init__
    if cups_import.import_needed ():
  File "/usr/share/printconf/util/cups_import.py", line 200, in
import_needed
    which = which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment

Then I cannot set up or modify any printer, I try to use CUPS web
console, this make me setup a printer, but it prints only the first
middle of a sheet.

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.47.3.19-1

How reproducible:
Always

Steps to Reproduce:
1. Start Printer Manager from GUI
2. Start Printer Manager from text terminal
3. Kudzu reconize a new printer and tries to set it up but it blinks
the screen

    

Actual Results:  In all que cases it doesn't starts or show me the
error Tracer (copied in the last blocks)

Expected Results:  The programs can be executed and let me setup a
printer as easy as it used to do.

Additional info:

I believe this problem was generated by the last update I have
downloaded. Because I didn't change anything and I registered it when
we tried to change some propetires and the program doesn0t start
Comment 1 Milan Kerslager 2004-09-21 09:52:46 EDT

*** This bug has been marked as a duplicate of 131563 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.