Bug 132665 - Patch to improve early boot with rhgb
Patch to improve early boot with rhgb
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 107121 FC3Target
  Show dependency treegraph
 
Reported: 2004-09-15 13:36 EDT by Daniel Veillard
Modified: 2014-03-16 22:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.82-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-17 16:20:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch suggested (1.82 KB, patch)
2004-09-15 13:38 EDT, Daniel Veillard
no flags Details | Diff

  None (edit)
Description Daniel Veillard 2004-09-15 13:36:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040805 Firefox/0.9.2

Description of problem:
the enclosed patch allow to get early messages and output from
/etc/rc.sysinint into the rhgb graphical boot.
This will only work with rhgb >= 0.13.1 but won't fail or
break on an earlier version


Version-Release number of selected component (if applicable):
initscripts-7.80-1

How reproducible:
Always

Steps to Reproduce:
1.boot with filesystem to be checked (tune2fs -c1 -C1 /dev/...)
2.watch the rhgb not see the boot 
3.
    

Actual Results:  no rhgb details 

Expected Results:  rhgb details should be fixed with rhgb >= 0.13.1
and the patch

Additional info:

I have seen once that fsck'ing the root file system then the
command return value seems to be >2 because I got dropped into
repair mode, but could not find in the patch why this is occuring
Comment 1 Daniel Veillard 2004-09-15 13:38:04 EDT
Created attachment 103874 [details]
the patch suggested
Comment 2 Bill Nottingham 2004-09-17 16:20:24 EDT
Will be in 7.82-1, with some minor tweaks.
Comment 3 Daniel Veillard 2004-09-18 13:05:53 EDT
Cool, thanks, I just pushed rhgb-0.13.2 if you want to have an idea
of the final result,

Daniel

Note You need to log in before you can comment on or make changes to this bug.