Bug 1327863 - cluster/afr: Fix partial heals in 3-way replication
Summary: cluster/afr: Fix partial heals in 3-way replication
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.7.11
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1318751
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-17 02:01 UTC by Pranith Kumar K
Modified: 2016-06-28 12:14 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of: 1318751
Environment:
Last Closed: 2016-06-28 12:14:18 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2016-04-17 02:01:20 UTC
+++ This bug was initially created as a clone of Bug #1318751 +++

Description of problem:
    When there are 2 sources and one sink and if two self-heal daemons
    try to acquire locks at the same time, there is a chance that it
    gets a lock on one source and sink leading partial to heal. This will
    need one more heal from the remaining source to sink for the complete
    self-heal. This is not optimal.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-03-17 12:57:55 EDT ---

REVIEW: http://review.gluster.org/13766 (cluster/afr: Fix partial heals in 3-way replication) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-04-12 12:06:17 EDT ---

REVIEW: http://review.gluster.org/13766 (cluster/afr: Fix partial heals in 3-way replication) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-04-15 05:51:10 EDT ---

COMMIT: http://review.gluster.org/13766 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 8deedef565df49def75083678f8d1558c7b1f7d3
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Mar 17 19:42:00 2016 +0530

    cluster/afr: Fix partial heals in 3-way replication
    
    Problem:
    When there are 2 sources and one sink and if two self-heal daemons
    try to acquire locks at the same time, there is a chance that it
    gets a lock on one source and sink leading partial to heal. This will
    need one more heal from the remaining source to sink for the complete
    self-heal. This is not optimal.
    
    Fix:
    Upgrade non-blocking locks to blocking lock on all the subvolumes, if
    the number of locks acquired is majority and there were eagains.
    
    BUG: 1318751
    Change-Id: Iae10b8d3402756c4164b98cc49876056ff7a61e5
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13766
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>

Comment 1 Vijay Bellur 2016-04-17 02:02:41 UTC
REVIEW: http://review.gluster.org/14008 (cluster/afr: Fix partial heals in 3-way replication) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Vijay Bellur 2016-04-17 05:46:25 UTC
COMMIT: http://review.gluster.org/14008 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 6b88d97c4a9e999180d77463e38ad14fc9d944cf
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Mar 17 19:42:00 2016 +0530

    cluster/afr: Fix partial heals in 3-way replication
    
    Problem:
    When there are 2 sources and one sink and if two self-heal daemons
    try to acquire locks at the same time, there is a chance that it
    gets a lock on one source and sink leading partial to heal. This will
    need one more heal from the remaining source to sink for the complete
    self-heal. This is not optimal.
    
    Fix:
    Upgrade non-blocking locks to blocking lock on all the subvolumes, if
    the number of locks acquired is majority and there were eagains.
    
     >BUG: 1318751
     >Change-Id: Iae10b8d3402756c4164b98cc49876056ff7a61e5
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/13766
     >Smoke: Gluster Build System <jenkins@build.gluster.com>
     >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
     >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
     >Reviewed-by: Ravishankar N <ravishankar@redhat.com>
     >(cherry picked from commit 8deedef565df49def75083678f8d1558c7b1f7d3)
    
    Change-Id: Ia164360dc1474a717f63633f5deb2c39cc15017c
    BUG: 1327863
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/14008
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 3 Kaushal 2016-06-28 12:14:18 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.