Bug 132808 - init devlabel ntpd iptables selinux upgrage reinstall partitioning packages
init devlabel ntpd iptables selinux upgrage reinstall partitioning packages
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: basesystem (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-17 07:31 EDT by C.H.
Modified: 2014-03-16 22:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-17 12:52:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description C.H. 2004-09-17 07:31:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
----------------------------------------------------------------------
Fc3T1 -- several different errors relating to installation, boot,
shutdown.
Sorry for the 'merged report' of various distinct bugs, but they're all
related to "basic system" fairly default installation / startup / shutdown
and I haven't been able to trace down which packaged components these 
various problems belong to.

----------------------------------------------------------------------
SYSTEM INSTALLATION error #1 --

FC3T1 had been installed previously on the system, then a reinstallation
via upgrade was attempted from the same FC3T1 install DVD.

During the original installation SELINUX was enabled in the install
option,
and the same is true of the options relating to the upgrade / reinstall.

REINSTALL BUG #1 When the upgrade/reinstall was attempted, a fatal error
resulted 100% of the time saying something about SELINUX already being
installed / configured / activated (sorry I don't have the exact messages)
and it refused to proceed to reinstall/upgrade.  The only solution
was to reformat the disk and do a from-scratch install onto the
formatted disc.

REINSTALL BUG #2 When the SELINUX error happened,
(possibly also another errror during the installer, I forget) the option
was given to save the error message to a floppy disc.  I chose that option
and believed it had saved the error log so I could submit it in a bug
report,
but apparently the disc ended up blank with no error log on it.  So there
looks like there's a bug in the "save the error message to floppy" code.
That's why I'm a big vague on the exact error above.
FURTHERMORE, actually, most of my systems don't have floppy drives at all,
I consider them obsolete.  Please provide additional options such as:
*) syslog errors / diagnostics / logs to another PC on the LAN.
*) stream ASCII message log to a user selected UDP or TCP IP address
and port
*) write error log onto USB flash disk or to USB hard disc etc.
*) save error information to the system's non-volatile DMI log
etc.

----------------------------------------------------------------------
SYSTEM INSTALLATION error #2 --

The code is probably functioning "as intended" but it's a "bug" in the 
design.  When the user is selecting a fresh installation (as opposed to an
upgrade), the user should be premitted to select his/her package
selections
FIRST, AND THEN be permitted to make partitioning selection /
repartitioning
choices after BEING TOLD EXACTLY HOW MUCH SPACE THE DESIRED INSTALL
ACTUALLY
MINIMALLY REQUIRES  on /, /usr, /usr/local, /opt, /var, /etc, /tmp,
swap, etc.

The way it is now one is just blindly left to guess or
"trial and error" experiment to see if anything uses /opt, or if it's all
in /usr, how much space is needed in /usr, and other system
partitions, etc.

*** ALSO I seem to recall it just flat out wouldn't let me create one
partition I wanted, probably /usr/tmp IIRC (because I wanted an
essentially
static /usr and any post-install local stuff like /usr/local and /usr/tmp
being on another FS).  I didn't check to see if /usr/tmp ended up being
a symlink to /var/tmp or /tmp, but if it's really forcing a writable /usr,
that's certainly not my preference!

----------------------------------------------------------------------
SYSTEM INSTALLATION error #3 --

IIRC there was a problem installing from a USB 2.0 DVD ROM that
one has successfully booted the installer from, and which ordinarily
works 
fine after the system is installed.  This is from rusty memory, but if
the USB 
mass storage drivers aren't loaded "at install time" to facilitate
USB DVD-rom/CD-ROM based installs, please do provide that feature.

----------------------------------------------------------------------

SYSTEM startup error #1 --  
Activating swap partitions: [ OK ]
restorecon reset context /etc/mtab->system_u:object_r:etc_runtime_t
/sbin/devlabel: line 895: /var/lib/devlabel/ignore_list: No such file
or directory
/sbin/devlabel: line 896: /var/lib/devlabel/proc_partitions: No such
file or directory
grep: /var/lib/devlabel/ignore_list: No such file or directory
/sbin/devlabel: line 920: [: -eq: unary operator expected
grep: /var/lib/devlabel/ignore_list: No such file or directory
/sbin/devlabel: line 144: [: -gt: unary operator expected
...[these repeat several times]...
Checking filesystems
...etc.

----------------------------------------------------------------------

SYSTEM startup error #2 --  

[Show details clicked during graphical startup]
INIT: Entering runlevel: 5
Entering non-interactive startup
...
ntpd 4.2.0@1.1161-r Tue Jun 15 21:05:33
ntpd: Opening firewall for input from 66.187.233.4 port 123[ OK ]
ntpd: Opening firewall for input from clock.redhat.com port
123/etc/rc5.d/S58ntpd: line 161:  2282 Segmentation fault     iptables
-I $FWCHAIN -m udp -p udp -s $server/32 --sport 123 -d 0/0 --dport 123
-j ACCEPT
[FAILED]
ntpd: Synchronizing with time server: [ OK ]

N.B. sync system time via NTP to clock.redhat.com was the selectable
option in the default FC3T1 installer configuration screen, so nothing
locally custom was done to create the configuration which was created.

----------------------------------------------------------------------
SYSTEM shutdown error #1  --  

Shutting down APM daemon: [ OK ]
ntpd: Removing firewall opening for 66.187.233.4 port 123 [ OK ]
ntpd: Removing firewall opening for clock.redhat.com port 123free():
invalid pointer 0x937a644!
/etc/rc0.d/K74ntpd: line 161:  2914 Segmentation fault    iptables -D
$FWCHAIN -m udp -p udp -s $server/32 --sport 123 -d 0/0 --dport 123 -j
ACCEPT
      [FAILED]
Shutting down ntpd:  [ OK ]

N.B. sync system time via NTP to clock.redhat.com was the selectable
option in the default FC3T1 installer configuration screen, so nothing
locally custom was done to create the configuration which was created.

----------------------------------------------------------------------


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. q.v. above details; install FC3T1 w/ SELINUX on & NTP server setup,
2. observe system startup / shutdown logs for errors
3. attempt (unsuccessfully) an upgrade type reinstall of the same box.
    


Actual Results:  see above 


Additional info:
Comment 1 Bill Nottingham 2004-09-17 12:52:58 EDT
Please, *one bug per bug report*.

Note You need to log in before you can comment on or make changes to this bug.