Bug 132812 - up2date fails - popup encountered cannot update until associated with a channel
up2date fails - popup encountered cannot update until associated with a channel
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-17 08:26 EDT by Bob Stent
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 10:37:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot of browser connection to rhn (30.27 KB, image/gif)
2004-10-01 14:51 EDT, Bob Stent
no flags Details

  None (edit)
Description Bob Stent 2004-09-17 08:26:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:

A popup with the following message is generated.
I have registered and have what looks to be a valid channel for this
system.
port 443 is open through firewall.
This system may not be updated until it is associated with a channel.

Version-Release number of selected component (if applicable):
up2date-4.0.1-1

How reproducible:
Always

Steps to Reproduce:
1. launch up2date as root
2.
3.
    

Actual Results:  Receive a popup message

This system may not be updated until it is associated with a channel.

Expected Results:  system would peform update

Additional info:
Comment 1 Suzanne Hillman 2004-09-30 11:39:25 EDT
What is the channel that the system thinks it's registered with?
Comment 2 Bob Stent 2004-09-30 14:03:13 EDT
Do you mean at redhat?
The channel shows as 'Red Hat Enterprise Linux ES (v.3 for x86)'

when I run rhn_check I get ...

Could not retrieve action item from server <Server for 
xmlrpc.rhn.redhat.com/XMLRPC>
Error code: -31
Error Message:
    Service not enabled for system profile: "bstent-rh"
Error Class Code: 31
Error Class Info:
     This system does not have a valid entitlement for Red Hat 
Network.
     Please visit 
https://rhn.redhat.com/network/systems/entitlements.pxt
     or login at https://rhn.redhat.com, and from the "Systems" tab,
     select "System Entitlements" to enable RHN service for this 
system.
Explanation:
     An error has occurred while processing your request. If this 
problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred 
and
     details on how to reproduce this problem.
Comment 3 Suzanne Hillman 2004-10-01 14:39:36 EDT
Huh. It shows that where? On RHN's website? Elsewhere?
Comment 4 Bob Stent 2004-10-01 14:40:42 EDT
It shows on rhn website
Comment 5 Bob Stent 2004-10-01 14:51:26 EDT
Created attachment 104640 [details]
snapshot of browser connection to rhn

gif of browser connection to rhn
Comment 6 Suzanne Hillman 2004-10-04 14:12:00 EDT
Have you reinstalled this system since you initially registered it? If
so, you will need to re-register. Remove the entry on RHN, then run
rhn_register to do this.
Comment 7 Bob Stent 2004-10-04 14:20:45 EDT
No, it has not been reinstalled.  This is the OS shipped on the 
system.
Comment 8 Suzanne Hillman 2004-10-04 14:48:33 EDT
Have you ever been able to up2date the system with the initial
settings? If not, you would probably be best off to remove the entry
and run rhn_register anyway. It's possible that something got messed
up or confused during the initial registration.
Comment 9 Suzanne Hillman 2005-04-08 10:37:28 EDT
Closing due to lack of reply in many months.

Note You need to log in before you can comment on or make changes to this bug.