Bug 132827 - Default gnome keyboard shortcut for "Take a screenshot of window" no longer work
Summary: Default gnome keyboard shortcut for "Take a screenshot of window" no longer work
Status: CLOSED DUPLICATE of bug 131304
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 131589
TreeView+ depends on / blocked
 
Reported: 2004-09-17 15:28 UTC by James Laska
Modified: 2013-09-02 06:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing the unexpected Keybinding value (52.68 KB, image/png)
2004-09-17 15:29 UTC, James Laska
no flags Details

Description James Laska 2004-09-17 15:28:39 UTC
# TREE rawhide-latest (at time of report FC3test2)
# ARCH i386
# KEYBOARD native laptop and Logitech usb multimedia keyboard
# gnome-panel-2.7.92.1-1

The default <alt>-prtscrn has always taken a screen shot
(gnome-panel-screenshot --window) of the window with current focus. 
This action no longer is triggered by the <alt>-prtscrn keypress. 
<alt> will still take a screenshot of the entire window (as expected).

I was able to work around this problem by reconfiguring the the
Keybinding for "Take a screenshot of window" by running
gnome-keybinding-properties.  I highlighted the appropriate action and
hit alt-printscreen.  The application then recording my keypress as:

   <Alt>Sys_Req

So does the default keybinding for this function need ot change for
new users so that they can utilize the window screenshot function
without changing their settings?  Has something internal with my
xmodmap changed (unmodified since fresh install last week).

So to further diagnos this problem.  I started gnome as a fresh new
user.  The gnome-keybinding-properties for the new user defaults to
<Alt>Print.  And that keypress appears to work!  The odd thing is that
when I click the "Window screenshot" function to change the
keybinding, and I press <alt>-prtnscrn  ... and it continues to show
up as:

   <Alt>Sys_Req

So I gather I'm having 2 issues here (which may require seperate bug
reports):

 1) my keybinding settings (I assume stored in $HOME/.gconf) from
previous FC3test releases appear to not work.  In order to get it to
work I needed to rebind the <alt>PrtScrn binding.

 2) For a new user, the gnome-keybinding-properties shows the "Take a
screenshot of window" binding as <Alt>Print.  But re-setting that
binding (to apparently the same key) then displays <Alt>Sys_Req.

Any thoughts/comments/concerns?

Comment 1 James Laska 2004-09-17 15:29:55 UTC
Created attachment 103952 [details]
screenshot showing the unexpected Keybinding value

Comment 2 Mark McLoughlin 2004-09-20 07:10:58 UTC

*** This bug has been marked as a duplicate of 131304 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:05:42 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.